Standby prob, MST don't help

C

corrado95

Guest
Hi,
I have been struggling a long time, trying to get my HTPC in standby and silent then.
The other day I got the tips about MST and thought that this should cure my problems. But it did not.
When I press "PC" on my MS remote (IR_USB), it start to go to stanby but it instantly comes up again. One thing that I can see during some seconds, is a message, telling me something about a current (ampere) problem in USB NAV. It says "click here", but I never can before it dissapear.
I have installed V0.9.49beta
Choosen S3 in MST and BIOS
One thing that I wounder about, in tab USB, "Enable USB S3 resume" is checked but grey. Why?
I also wounder about that you don't do a "save" after the changes after install, how does the program work?
I have choosen "enable log options" and "log task lists"
My MB is Asus P5GD2-X
KB and mouse, MS bluetooth-USB. I have taken these out, same problem.
5VSB is on

Any ideas?
 
C

corrado95

Guest
I can add one thing.
When it restart again, and remote don't work, I can see in device manager/USB that the unit for the remote is now gone!
I have to make a cold start to make it work again.
 

hveijk

Novice Member
The current warning you are getting tells you some USB port is overloaded, proper USB ports have a current limiter. This might be caused by a broken device (remote?), a broken motherboard or because you are using a high power USB device on a non-powered USB hub.

Maybe there is more on the warning in the event viewer.

Try moving the remote to a different USB port to see if the warning stays.

Try the remote on a different PC to see if the overload problem moves with it.

This overload thing is probably also causing your wake problem.

Enable USB S3 resume only make sense when your system uses the S3 sleep state, it is disabled when you are using S1 or S4.

Are you using an administrator account? If the current user does not have admin rights it is unable to change the sleep state. Future versions of MST will warn on this. Maybe your system is still using S1 or S4 because of these rights.

All settings are activated from the moment you make them, unless they require a reboot.
 
C

corrado95

Guest
It seems like I have solved this problem finally!
I solved it by setting the jumper for the rear USBs to +5V (instead of +5VSB). Can it really be that ASUS has made an error in their manual? The manual also said that +5VSB should be default. It wasn't. Default was +5V. If it was +5VSB that should be the default, it looks like it was, but the text was wrong in the manual.
I have written about my hibernate problem on Asus P5GD-X forum, a year ago. One could think that Asus tech people should check these Q and answer them. Is it to ask for to much?
I thought I had tried this setting earlier, perhaps it was before I added the change in the registry?
 

tman

Well-known Member
You would normally only use the +5VSB USB switch setting if there was a device connected to the USB port that you wanted to be able to bring the machine out of S3 (i.e, the remote). Any othe device should be set to standard +5V. This should stop other USB devices bringing the PC out of standby.
 
C

corrado95

Guest
hveijk
Enable USB S3 resume only make sense when your system uses the S3 sleep state, it is disabled when you are using S1 or S4.
Ihave, as I wrote, choosen S3 both in BIOS and in MST. Why is it checked but greyd out?

Are you using an administrator account? If the current user does not have admin rights it is unable to change the sleep state.
I have adm rights.

If I have the program started and want to close it, I get a warning that tells me the settings will be disabled. I do not understand, should MST allways be running?

If I choose "reboot once every day", is there a way to see that this is done?
 

hveijk

Novice Member
Nice to see you got things worked out!

Some devices definitely don’t like to be powered during suspend. Removing 5VSB from them makes them reset at every suspend, maybe this is the case with your device (unless it’s the remote which need the 5VSB to be able to wake the system)

“Enable USB S3 resume” is an OS setting. MST always shows it current status. If the selected sleep state is S1 or S4 it will be grayed out because these sleep states do not require this setting.

Your system seems to be configured for S1 or S4. What “Supported sleep states” does the “sleep state” tab show? And what “Selected sleep state”?

Could you export the following registry keys and mail them to me (the address is in the about tab):

HKEY_LOCAL_MACHINE\SOFTWARE\Herman van Eijk\MceStandbyTool
HKEY_CURRENT_USER\SOFTWARE\Herman van Eijk\MceStandbyTool

If you are only using the configuration options of MST you don’t have to install or keep it running.
If you would like to use some of the advanced features which will be made available once the program is installed you will have to keep it running. It will start by itself at boot time.

In that case it will give you the warning you mentioned when you try to close it, just minimize it.

Search the log file for “reboot” to see if they took place. Some problematic systems using S3 and all systems using S4 are unable to distinguish automatic tasks (guide updates and scheduled recordings) from waking for user interaction. In this case you should use the latest public release (0.9.54) which will reboot these systems properly.

It might take a few days to detect the system is unable to do these automatic tasks when using S3. Just wait and see, after 20 standby actions from which non is an automatic task it will start rebooting.

Herman
 

hveijk

Novice Member
Corrado95,

I have read your mail. This is what happened (I think):

You selected S1 in MST. After that you disabled S1 in the BIOS setup.

Internally MST still thinks it uses S1 (which it is not because it is disabled) but shows (by error) S3 in the “sleep state” tab so you are convinced it uses this sleep state.

Reselect S3 in the “Sleep state” tab and it probably will be solved.

I will fix this in the next release of MST, thanks for pointing it out to me.

Feedback like this will defenatly make MST more bulletproof.

Herman
 

Similar threads

The latest video from AVForums

Podcast: TCL C815 TV, Denon & Huawei wireless speaker reviews, New Sony 4K PJ's and more
Top Bottom