Standard Sky Box not turning on

john10001

Standard Member
I have a standard Sky box that is not turning on, its stuck in stand by on the red light.

Is this a power supply issue or some internal power issue?

It's a Sony S760 box.

If there's nothing I can do to fix it, are there any places you can recommend sending it off to for getting repaired?

Thanks,
John
 

Broadz

Distinguished Member
No point repairing a standard Sky box. They sell for about a fiver on eBay. It'd cost a lot more than that to get it repaired.
 

tamthetim

Active Member
Hi,

Have you tried a forced download? My sky+ box gets stuck in standby and that usually works, although I fear its on its way out. Google it for your model.

Cheers, Tam
 

john10001

Standard Member
Hi,

Have you tried a forced download? My sky+ box gets stuck in standby and that usually works, although I fear its on its way out. Google it for your model.

Cheers, Tam

Tam,
Yes, I've done the forced download. It updated everything but I still have the same problems. It did actually work for a few days without too many problems but now it is permanently in stand by again. Once in a blue moon I am lucky if I am able to get it out of standby but it doesn't stay on for long.

I have also tried to access the hidden installer menu to check if it could be an LNB issue. I am pressing 4 0 1 Select, but I get nothing. I end up in Picture Settings or just an information screen without any other options. Would be great to know what I am doing wrong here and if this is the right combination to press for the Sony S760 box? Though I suspect it is a power issue and nothing to do with LNB.

Thanks for any help
John
 

Stevenage Neil

Distinguished Member
A LNB issue will not cause the box to remain in Standby.

The correct sequence is Services/4/0/1/Select
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom