SSD C: drive stopped working...sort of

GloopyJon

Member
Hi,

I have an OCZ Vertex 2 120GB SSD which is my C: drive and contains Windows, most of my applications and some data (I put the bulky stuff onto hard disks). About a week ago, things started going wrong. First of all, Microsoft Money stopped loading. A day or two later, the other Office applications stopped loading. Then it started getting temperamental about booting up, and finally it stopped booting altogether. Now when I boot up, the drive is recognised in the BIOS but it says there is no operating system.

When I boot from my Windows 7 installation disk, it does not identify the drive - I try to do a Repair but it doesn't show the disk (or any other) in the list of installed partitions (the lack of any others is probably OK since they don't have Windows installations on them).

I took the SSD out and connected it to my laptop via a USB adapter (something like this), and it seemed to be fine. I copied my entire Users folder to my laptop, which took ages but seems to have worked alright (all of the files I have opened to test it have been fine).

At the moment, I'm a bit stuck since I can't do anything with it in my PC. My next planned step is to flash the firmware, for which I will try to connect it to another PC as a secondary drive. Not sure if that will help, though.

Does anybody have any ideas or suggestions? All help gratefully received! :lease:
 

Din0Su4r

Active Member
As silly as it may sound, try a different SATA cable and port!
Also try updating your BIOS.
For the rest I'll leave it to the more experienced.
 

GloopyJon

Member
I tried different SATA cables and ports (including ones which work with the hard disks in the computer) and it's the same. I tried to update the firmware on the SSD drive but I'm not sure whether it actually did anything (the firmware update program provided by OCZ did not provide very concrete feedback). I haven't updated the BIOS on my motherboard, but might do that some time.

In the meantime I have just reinstalled Windows etc. on my hard drive, and the SSD is lying unused on my desk. I should try to contact OCZ too, as it should still be within the warranty period, but I don't have a lot of time to spend on things like that at the moment!
 

Baldfox

Active Member
Sorry to hijack the thread. I had a similar problem. One minute the SSD was working fine, I did something particularly memory intensive (re-encoded a film), it made a lot of noise, and then the fan stayed on. I restarted the pc, and now I have a boot loop. Says bootmgr is missing. I've tried rebooting into recovery, i've done the whole bootrec /fix mbr/fix boot etc..i've done listpart, diskpart, make active etc... All that happens, is i can get past the bootmgr missing, but the windows 7 load screen comes up (with the balls/bubbles appearing) and then it just shows me a BSOD that I don't have time to read, and goes into a loop and restarts. I'm not aware of any more updates i've done lately, and had the disc for about a year.

I've got gparted... shows me the 64gig SSD has 2 partitions, one of 100mb and the other the rest (63ish gig).
I've tried making either partition the boot (by enabling the flag), but it just doesn't make a difference.

It's an OCZ SSD, 6gb/sec jobby on an Asus motherboard. Anyone have any idea of anything else I can do ? In DOS, I can browse the disc so I think it's just windows that has thrown a spanner. I also noticed the drive went from being C: to F:... i've unplugged all other drives in the system, never used Raid.. just running out of ideas.

Any suggestions ?
 

EndlessWaves

Distinguished Member
It may just be that the filesystem has gotten screwed up, especially if the disk is partly or completely working as a secondary drive. You can try reconstructing it manually but assuming you've got everything backed up I find it usually quicker to just wipe and reinstall.
 

Baldfox

Active Member
not got a complete image of the disk backed up.. so I can pull off the data, but reinstalling everything, and then trying to piece together email folders etc, not ideal. Anyone know of a program or method to fix the partition table, or clean it up ?
 

12harry

Distinguished Member
This is a bit worrying - why should moving data cause the drive to corrupt, surely the memory doesn't Wear-out the drive, or is there a local (micro-)heating issue, perhaps and this has caused a skipped-bit.

Once it's done it once, does this behaviour repeat itself, given a similar data-busting session.

Has anyone noticed these Solid-state drives getting even slightly warm under bulk-data actions?
 
Last edited:

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom