Spitting sound from SONY STR-DA5300ES amp

M17CH3LL

Standard Member
Hi,
I sometimes get a kind of spitting sound from my amp I think?...when watching BD's. I say amp because, when I skip back and replay, it doesn't happen again...not at the same point in scene anyway.
Can anyone enlighten me on this issue? I thought it was maybe caused by dirty/scratched disks, but these are mostly new, and defect free as far as I can see. Does it seem I have a fault with my amp or could it be electrical interference causing this sound?
Any clues would be greatly appreciated.
 

Mark.Yudkin

Distinguished Member
Hi,
I sometimes get a kind of spitting sound from my amp I think?...when watching BD's. I say amp because, when I skip back and replay, it doesn't happen again...not at the same point in scene anyway.
Can anyone enlighten me on this issue? I thought it was maybe caused by dirty/scratched disks, but these are mostly new, and defect free as far as I can see. Does it seem I have a fault with my amp or could it be electrical interference causing this sound?
Any clues would be greatly appreciated.
Could it be mains-borne RF interfence (I had this between the old fridge and the TV)? This is usually caused by a fridge, airconditioner, hair-dryer, some types of energy savings lamps, turning on or off. It is most simply resolved by using RF filter plugs, which you can get from your local electrical supplier.

Here's a popular UK adapter with 6 sockets. Use it for both the player and the amp, and any other A/V kit you use.
 
Last edited:

The latest video from AVForums

Panasonic HZ2000 OLED TV Review: The best OLED for movie viewing in 2020
Top Bottom