Question Sound through PC Speakers AND Headphones

Discussion in 'PC Gaming & Rigs' started by BenjaminAV, Apr 3, 2016.

  1. BenjaminAV

    BenjaminAV
    Novice Member

    Joined:
    Feb 14, 2014
    Messages:
    14
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    4
    Ratings:
    +0
    Specs :-

    Asus Z170 Pro Gaming
    Creative 7.1 Speakers (only front 2, Centre and Bass plugged in due to space constraints)
    Onboard Realtek HD Audio (Rear - usual 3.5mm connectors)
    Front Panel 3.5mm headset and mic
    Turtle Beach X12 Headset

    Asus HD Audio manager.
    Windows 10

    Firstly I'm a real noob when it comes to sound settings. I have very little clue what the different "Devices" do or many of their settings. No idea what "Stereo Mix", AC97 "Line in", "Default Devices", ... are. So please be patient. :)

    What I'd like to do is tell the computer to play all the sounds through both the front panel and the back panel so I can get the same sound from both speakers and headset simultaneously.

    I have tried every conceivable combination of the settings but even when I Eventually get it to work, it stops working on reboot or if I unplug and replace any of the jacks.


    I've even resorted to "lying" to the computer when I plug a jack in to say I've plugged a "speaker" in the front panel when really its my Headset but the PC always seems to be 1 step ahead of me forcing it not to work!

    Can anyone explain PC sounds, devices and drivers basically and let me know what BIOS, devices, defaults and software settings I need to select to achieve this?

    Its working as I speak with the settings in the picture but it wont on reboot (and telling it to "Play different streams" hasn't worked before either)

    Many thanks.




    SpeakerSetup.jpg
     
  2. BenjaminAV

    BenjaminAV
    Novice Member

    Joined:
    Feb 14, 2014
    Messages:
    14
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    4
    Ratings:
    +0
    I have reinstalled all my drivers and everything from scratch regarding sound. I have narrowed it down.

    My left and right front speakers work fine.
    When I plug my Headset in the front panel it is also fine on both the speakers AND the Headset but comes up with "Which Device Did You Plug In" on the Asus HD software.

    The only checkbox available is "Headphone"

    If I alt+F4 out it's perfect.
    When I reboot or click "next" (which is the only option) it starts muting channels and messes up everything.

    So basically I need to know how to keep the front AND rear outputs open (in the "limbo-like" state) before the software messes it all up again.

    Surely there must be something simple I'm missing here!
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice