• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Sound problems with Humax PVR Freesat

Spannerhead

Standard Member
I've got the original Humax PVR Freesat box, had it just over a year.

I run the sound through a Pioneer AV amp (4 years old) and Yahama 5.1 speakers.

I've noticed when watching Freesat from the Humax box there is a very tinny (as in tin, not tiny :)) sound coming from the speakers, especially bad when people on the TV are talking. When I put my ear to the speaker I can hear a high pitched squeeky distortion, it's driving me nuts.

It's connected to the amp via optical cable. I've tried swapping the cable, no difference. When I play a DVD or a feed from my Popcorn hour, no distortion. If I play the PVR sound out through the basic TV speakers (it's a Panasonic Viera 720p plasma) no problem.

So, I'm assuming it's coming from the Humax box, I've checked my signal strength and it's 95% - so the sound should be fine. Oh yes, and it's on all channels.

Any thoughts?
 

grahamlthompson

In memoriam
By all channels do you mean HD channels as well as SD. If so it's very odd as HD channels use Dolby Digital 2.0 or 5.1 a completely different system to sd MP2 sound. What happens if you listen to the BBC HD test card with 5.1 sound check broadcast every day about 10:30 am on the HD preview loop
 

Spannerhead

Standard Member
Ahh - haven't checked the HD signal, though I'm sure that's ok as I'm certain I would have noticed the hiss/crackle when watching HD.... I'll check tonite. Thanks
 

mccg

Established Member
I think this is mp2 compression artefacts...

If I am right close to my speakers (5.1 from Onkyo amp via HDMI), I can here a high pitched distorted "shadow" of the normal sound.
It was a lot worse when I had ntl TV.
It probably gets enhanced by things like Pro-Logic.
(It was the same on my old Sony amp)

Edit: It should not be present when watching HD with Dolby Digital/AC3 sound
 
Last edited:

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom