• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Sound problems with Blu-ray discs on Sony BDP-S370

ToxicStar

Standard Member
I have recently bought a new Sony BDP-S370. All part of the major HD uplift. The only part that remains from my old setup is the Pioneer VSX-808RDS. I have had this for a “significant” numbers of years and it has always done me proud.
Even now the only issue I have is with blue ray disc's, these are all coming down the connection as “DTS”. This works but it has a tendency to drop back out to for a second to Dolby pro-logic before coming back to DTS. This happens on all the blue rays particularly around the start of a movie. I have even traded connections between coaxial and optical with the same results. As an example WallE has problems in the first 15 minutes then settles down for the rest of the movie. I initially thought it was the disc but the problems happens all my other blue ray discs.
I have the BDP-S370 on the home network and it is has the most up to date firmware. Discs not generating DTS work fine.

The questions I have are the obvious ones.
- What could the problem be?
- How can I prove the fault ?
- Is the fault with the blue ray player or the old receiver ?

I have been looking at a new receiver (an Onkyo TX-SR308) but at £200 I need to be sure the fault is with the receiver first.

All help and advice welcome.
 
Last edited:

The latest video from AVForums

SVS Prime Wireless Pro Powered Speakers - Review Coming Soon
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom