Quantcast

SonyKDF E50A12U help for ghosting check 60hz

phill1979

Standard Member
The engineer came to replace the part this morning, i was wiiling to let them do this despite be almost certain that it would not work, not only did it not work the tv made a funny clicking sound and lost all power and was unable to turn on, it is being taken away to be looked at but the engineer did not hold much hope that it will be fixed. So i am sitting watching a 7 year old 20ins LG, all this the week gears of war is out and the ashes start :(
 

gibipeti

Standard Member
its terrible, but let you see the good side, you will have a brandnew tv
i must minimum 1 month wait, until my tv's optical block resending to the factory

The engineer came to replace the part this morning, i was wiiling to let them do this despite be almost certain that it would not work, not only did it not work the tv made a funny clicking sound and lost all power and was unable to turn on, it is being taken away to be looked at but the engineer did not hold much hope that it will be fixed. So i am sitting watching a 7 year old 20ins LG, all this the week gears of war is out and the ashes start :(
 

gibipeti

Standard Member
But i read, that 2 members( scoopex and kicker008) tv had repaired with optical block replacement !!

As dazzyman has stated, nothing could be done to repir his tv, optical block included....that's why they offered the dude a refund.

Also, any non-region2 dvd i watch now is ghost-mungus.....it even starts to give me a headache as my eyes are trying to focus on a double image..... :mad:

So it looks like all us KDFE50 owners are going to be toying with new tellies after a shedload of hassle and incompetence.

Bravo SONY!!!! how can they get away with continuously releasing shoddy, untested product?

Grrrrrrr.......

Rich
 

d123456

Standard Member
I have the exact same problem.
I hoped I could provide additional information but everything has been covered already.
Indeed anything 60hz (except vga, which works fine with 60 hz) produces a blue ghosting image.
I have tested this with everything:
SCART RGB
SCART composite
Component
video in (on the side of the set)
HDMI

The only thing I am unable to check is the S-video, but I take it it also displays the blue ghost:)

Called Sony and I talked to a guy at Sony. He might be coming over on friday.
He said he has a firmware update that fixes the 60 Hz problem. I hope he will be able to fix it with that. I told him about the optical block and he said that that might no be the cause of it.
He said the optical block is the part that devides the colors.
I will let you guys know about this, how it goes.
Great thread, thanks to all those that participated.
I play my DC via VGA and it plays fine, but the VGA port is obviously not made for gaming. For games that run 60 FPS. There are loads of strange side effects like the set is not able to keep up with the VGA source. Really strange even when I set it on the smallest resolution 640 X 480. he set is still sstruglling. I bet the Component and HDMI ones are the ones to be used for gaming.

One tip though for switching channels etc.
You can press the OK button and you get a pop up with channels that can be selected but you can also press left or right and this switches between tv and av channels. In this way you can set the set back to 50 hz quickly.
Later guys, Oh yeah I'm new here, great forum and good members:hiya:

EDIT:
Any other things you guys want me to ask or he should look at?

EDIT:
They just called me and they'll be coming over on this monday the 27th.
So till then.
The guy informed me that they had to fix this problem for X-Box owners.
Probably because more Xbox games support 60 hz modes.
It is a firmware upgrade.
I will look for anything weird after effects when they fix it.
Now it becomes apparent why few Ps2 games have this option
 

SportiveUK

Novice Member
Called Sony and I talked to a guy at Sony. He might be coming over on friday.
He said he has a firmware update that fixes the 60 Hz problem. I hope he will be able to fix it with that. I told him about the optical block and he said that that might no be the cause of it.
Well this seems more promising. I think I will wait until your man has been before going any further because I am guessing a firmware update means the TV won't need to leave your living room!
 

antilles

Novice Member
d123456,

this sounds like it's too good to be true! I hope it is true!

Just do us a favour and tell the bloke how many people on this forum are anxiously awaiting this fix!!

Thanks

Rich
 

antilles

Novice Member
I've just spoken to a man called BROWN who is a technical supervisor at SONY....he says that these tv's are not designed to display at 60hz and that if there are any ghost images, then that is normal......

You can imagine the arguments i had with this ******...

He says there is no known fault with these tv's

He says that this range of tv's are NOT designed to run at 60hz edit

He says the reason PS3 is delayed here is compatibility issues (60hzetc.) with our tv system edit

he says the re are no firmware upgrades for this tv...

he says that if i take my tv somewhere to be "fixed" they will chrge me full price for wasting their time....


he says that it's normal for ntsc dvd's (which are displayed at 60hz) to have ghosting....

he says microsoft consoles are incompatible with sony tv's....

he says that this forum is worthless and not woth his time talking about....


if this guy was behind a counter and i was face to face, i would have chinned the thick c*nt by now....

i might have to email the gadget show and see what they have to say about this....


rich
 

d123456

Standard Member
I've just spoken to a man called BROWN who is a technical supervisor at SONY....he says that these tv's are not designed to display at 60hz and that if there are any ghost images, then that is normal......

You can imagine the arguments i had with this ******...

He says there is no known fault with these tv's

He says that this range of tv's are NOT designed to run at 60hz edit

He says the reason PS3 is delayed here is compatibility issues (60hzetc.) with our tv system edit

he says the re are no firmware upgrades for this tv...

he says that if i take my tv somewhere to be "fixed" they will chrge me full price for wasting their time....


he says that it's normal for ntsc dvd's (which are displayed at 60hz) to have ghosting....

he says microsoft consoles are incompatible with sony tv's....

he says that this forum is worthless and not woth his time talking about....


if this guy was behind a counter and i was face to face, i would have chinned the thick c*nt by now....

i might have to email the gadget show and see what they have to say about this....


rich
Dealing with idiots should be done in calm and civil manner.
Kindly ask his full name and first ask the name of his supervisor.
After the name has been written down. Ask to speak with him.
And kindly and in a civil manner ask him again.
Remain calm and civil in any case.
The manual clearly states the set is compatible with 60 hz.
You can always return the set to the store. Just say it is unacceptable and that you're using the tv set for video editing and that the ghosting effect makes the tv useless. Brag and boast untill they give a refund. I'm thinking of doing the same thing if he can't fix it
Good luck, keep us updated. Don'take no for an answer. Call again and hopefully you'll speak to somebody else. Perhaps you could even specify that you'd like to talk to the most capable person to deal with very technical tv stuff and that your problem is complex.
 

SportiveUK

Novice Member
He says there is no known fault with these tv's

He says that this range of tv's are NOT designed to run at 60hz edit

He says the reason PS3 is delayed here is compatibility issues (60hzetc.) with our tv system edit

he says the re are no firmware upgrades for this tv...

he says microsoft consoles are incompatible with sony tv's....
Well if that's the kind of answer I get when I inform of my problem then I'll be straight back to the shop demanding a full refund as the TV is not fit for purpose i.e. use with the 360. I specifically told the shop that my primary use was for the 360 (which it has been for the past year) and he said "it's a superb choice then".

I shall await the results of d123456's firmware update before starting my mission to get it all fixed...
 

antilles

Novice Member
Bear in mind that this man BROWN is a TECHNICAL SUPERVISOR...so knows his stuff....he himself stated more than once about being FULLY TRAINED etc.

It's just strange that when i rang last week and spoke to customer services, the operator said "hang on a minute..." went to check with a colleague, came back on the line and said, "i've just had a word with a guy who's an expert on the KDFE tv's....he says it's a hertz problem and knows all about it....he's had to fix this problem for a few 360 owners...if you take it to the local service agent, they should be able to fix it."

Amazing, innit?

Rich
 

phill1979

Standard Member
Just got a phone call, saying the have managed to repair it and it will be back on monday, So i will wait and see but i have a feeling it wont be fine
 

antilles

Novice Member
One more thing Phill, make sure you check the exterior of the telly for any marks or scratches, especially to the screen.....

Obvious, i know, but you know what it's like when you get caught up in the moment of a loved one returning home!!

Rich
 

paddy512

Standard Member
I also seem to have now developed this problem when connected up to my X Box 360. I bought the TV from Comet in April this year. Do I need to contact them re a repair? Many Thanks
 

antilles

Novice Member
All Comet will do is say that it is still covered by the manufacturers warranty, so you'll have to ring Sony.....

Rich
 

perttijeesus

Standard Member
Is it the same for the rest of you, that when I turn on the tv and straight away switch to a 60hz input, the ghosting can't be seen. It takes a few minutes to appear, but then it is there. Don't remember seeing it when the tv was new. Hope it really is a software bug and can be fixed with an update.

Im pretty sure the problem is not with the optical block as 50hz is fine. Why it is happening now and not with a new set, is odd. Maybe some chip is dying? Might be a bit hard to fix if thats the case. Does the set get some kind of over the air firmware updates that might be broken? It does for the freeview tuner, but what about the set itself?

Might the problem be in the Trident svp ex chip. That is what should handle accepting the signals. Or in the chroma decoder?
 

perttijeesus

Standard Member
Hm, maybe not the svp ex, as that would probably not affect the menus? I remember that some of us models had some kind of problem, that when they had been used 1200h, they would not start up. Maybe this is something odd like that. Something that happens after some amount of usage. As it seems possible, although very odd, to get some kind of odd behaviour after a fixed amount of time.
 

Kirby

Novice Member
I agree it does seem odd that this problem would develope over time, however I have now started to notice it after three months of usage. I can't really imagine the problem being there before because I usually find a fault in everything and after watching my fair share of ntsc films I hadn't noticed ghosting before, that is until yesterday while playing my ps2 after setting it to Pro scan.
I will have to keep an eye on this thread now and cross my fingers that this firmware update is real and works, the sony is a replacement from Currys to a TV I had which also failed to do its job properly.
 

d123456

Standard Member
Im pretty sure the problem is not with the optical block as 50hz is fine.

Might the problem be in the Trident svp ex chip. That is what should handle accepting the signals. Or in the chroma decoder?
Why do you say it is not the optical block when so many members in this thread have commented that that is what fixed their tv's? What do you suspect? That the trident svp ex chip was also calibrated on the same day they changed the optical block? Please elaborate. I'm curious to find out. Could you tell us some more about the parts you describe?

Oh well, my appointment is delayed until thursday. The guy from Sony said that the software was not in yet. Appointment is delayed until thursday afternoon. He told me the optical block is an expensive piece that is not kept in the Dutch inventory and would have to be ordered if it would be necessary.
I'll Keep you posted.
 

perttijeesus

Standard Member
Why do you say it is not the optical block when so many members in this thread have commented that that is what fixed their tv's? What do you suspect? That the trident svp ex chip was also calibrated on the same day they changed the optical block? Please elaborate. I'm curious to find out. Could you tell us some more about the parts you describe?

Oh well, my appointment is delayed until thursday. The guy from Sony said that the software was not in yet. Appointment is delayed until thursday afternoon. He told me the optical block is an expensive piece that is not kept in the Dutch inventory and would have to be ordered if it would be necessary.
I'll Keep you posted.
Just the fact that there seem to be people for whom it hasn't helped to change the block. The engineer whas right in that the block devides the colors, but I don't really know what kind of circuitry there is on that thing.

The thing is, I would suspect that it is not that different for the lcd panels to display 50hz or 60hz. It probably displays the same way all the time, as lcd panels dont really have a refresh rate the same way crt's do. Different refresh rates are just probably handled in the decoder chip, or some processing chip. This is not a fact, just a guess.

I really really hope the firmware update fixes it. The Nintendo Wii is going to be launched an 2 weeks and I cant really send my set in right now. Anything that can be fixed at home would be preferrable.
 

phill1979

Standard Member
Got my set back this morning and all seems fine now, there is no ghosting in 60hz. However now when i change from one sky channel to another, the search/scan banner seems to go dark and takes a couple of seconds to go back to normal.
 

perttijeesus

Standard Member
Got my set back this morning and all seems fine now, there is no ghosting in 60hz. However now when i change from one sky channel to another, the search/scan banner seems to go dark and takes a couple of seconds to go back to normal.
Good to hear! Any idea on what they did to it?
 

Similar threads

Trending threads

Latest News

Sony XH81, XH80 and X70 TVs now available in UK
  • By Andy Bassett
  • Published
TV sales rise as UK stays home
  • By Andy Bassett
  • Published
AVForums Podcast: 30th March 2020
  • By Phil Hinton
  • Published
UK telecoms come together to keep country connected
  • By Andy Bassett
  • Published
Sharp and NEC display venture to push 8K + 5G tech
  • By Andy Bassett
  • Published
Top Bottom