Sony W95 series (KDL-55W955B/ 65W955B) BRAVIA TV owners' thread

aygo1989

Active Member
Ok so I took the bullet and purchased this set from JL. The reviews done it no justice, ok I can see the blacks are a slight issue but compared to the w829 the colours make up for that by a long distance. When testing the W829.. it was far too dark and depressing for me with no real colour. Unfortunately when unboxing my set I discovered some dimwit hung the plug over and against the tv screen. The only issue I can see is a black finger like print close to where the plug was and a bright light that shines down the bottom left side of the screen. Motion could be slightly better but hey this is a decent tv while waiting for a sony 4k with low input lag!

John Lewis are sending a final replacement on Thursday so fingers crossed!
 

Sanad Saad

Novice Member
I am very happy with mine except that I get this white light across the top and bottom when I turn the volume up. Should I send to JL for repairs?
 

JB1970

Active Member
KDL-55W955B. I have a customer who's set won't display the output from his CCTV recorder on any HDMI input. The signal output is 1920 x 1080 at 60Hz (Hikvision NVR) All of his other equipment works - Virgin Tivo, Blu ray player etc on any of the inputs but not the CCTV (though it did when I installed it). I suspected the CCTV recorder was faulty but have now tried it on 5 other TV's of varying age and manufacturer (2014 HD ready Samsung, Samsung NU8000, Samsung QE75Q90R, Watervue bathroom TV and one other) and it syncs to the signal and displays normally.

I'm guessing the issue is specific to 1080P at 60Hz. Has anyone else had any experience like this? The TV is on up to date firmware and has been factory reset as a precaution and it's not the HDMI cable itself. TIA
 

The latest video from AVForums

Podcast: CES '22 TV Announcement Round-up, Plus, Most Anticipated Movies of 2022 and More...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom