1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sony VPL-X1000 Projector Lamp/Cover Light stays on

Discussion in 'Projectors, Screens & Video Processors' started by bob2005_wow, Mar 3, 2005.

  1. bob2005_wow

    bob2005_wow
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi
    I need some help, Does anyone know what it means when the used Projector I purchased on EBAY, the lamp is not turning on, I get the on Green light come up then within a few seconds, The Lamp/Cover light comes on and no lamp.
    I only had this projector delivered this afternoon and I sure would like some help to see the lamp come on.
    If anyone out there has the same type of projector, help would be very appreciated.

    Cheers
    Bob
     
  2. matblack

    matblack
    Active Member

    Joined:
    Jul 30, 2003
    Messages:
    404
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +10
    http://www.docs.sony.com/release/VPLPX20.PDF

    Check out the description of the lamp/cover light on page 11 of this manual, its for another unit but I am sure the function is the same.

    It looks like the bulb is dead but may just be that the cover over the lens and/ or air filter is not on securely

    See my response on your other thread too

    MB
     
  3. bob2005_wow

    bob2005_wow
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I just had to fork out another $665 for a replacement lamp, and I am waiting for it to arrive tomorrow,,,

    Thanks again

    Bob
     
  4. matblack

    matblack
    Active Member

    Joined:
    Jul 30, 2003
    Messages:
    404
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +10
    I hope those are Australian dollars :eek:

    MB
     

Share This Page

Loading...