Sony STRDB930 Centre Channel clicking prob

Discussion in 'AV Receivers & Amplifiers' started by steveadams99, Mar 14, 2005.

Tags:
  1. steveadams99

    steveadams99
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi,

    I have a STRDB930 in a typical AV setup. The amp is around 4 years old.

    There is an intermittent fault, generally when the amp is first turned in which the centre channel cuts out and the amp (speaker relays??) clicks furiously. The clicking will then stop and the channel will be mute, only to "click" back on some time later.

    This could be minutes or hours. Lifting a corner of the amp, or changing the speaker selector (A/B/Both) sometimes forces a click and chance recovery.

    Anyone have any ideas on the issue or who can fix it in the UK? Approx costs would be a help, as I may just get a new amp if it is £100s.

    Thanks
     
  2. steveadams99

    steveadams99
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Forgot to mention, also happens when changing input selection (say from Sky to CD).

    Presumably the relays get re-initialised.


    Steve
     
  3. pjclark1

    pjclark1
    Well-known Member

    Joined:
    Jul 19, 2004
    Messages:
    4,463
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Thailand
    Ratings:
    +271
    try a reset
    turn off, turn on my holding on button for 5 seconds, enters demo mode
    turn off and on, amp is now reset.

    My 3 year old plays with the buttons, and gets it into all sorts of funny modes
    LED on the volume control on mine is now off, dunno if its broken or turned off.
     

Share This Page

Loading...