1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sony STRDB-925 Problem!

Discussion in 'AV Receivers & Amplifiers' started by Hammers, May 29, 2001.

Tags:
  1. Hammers

    Hammers
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi Guys,
    It seems like a lifetime since I first bought this amp some 3 years ago and it has served me very well.Although it doesn't compare to the Mid/High end Yamaha's and Denon's it does deliver DD and dts very well.However I do have a slight problem when adjusting the volume whilst listening at resonably high levels.When I alter the volume, be it higher or lower, I get what I can best describe as a "distorted crackle" through the front 3 speakers.
    It's not a major problem as it only does it when I alter the volume which i rarely do once the film has started and it only tends to do it during excessive soundtrack moments.However it doesn't sound right and I wondered if anyone else has encountered a similar problem with this or the 930/940?

    Cheers.
     
  2. Timh

    Timh
    Well-known Member

    Joined:
    Sep 14, 2000
    Messages:
    4,806
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Altair-4
    Ratings:
    +128
    I have the 925 and its fine, but going back about 20 years I used to own an Amp which suffered from this fault, I believe it turned out to be dust in the control mechanism of the volume, I cleened it out and all was fine.
    Unplug before you play with it, you could try one of those electrical spray cleaners to clean the contacts in the volume.
    But then again I could be totally wrong.

    Tim
     
  3. Hammers

    Hammers
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Cheers Tim,I'll give that a try.
     

Share This Page

Loading...