Sony str-dn1080 sound cutting out earc

SnakePlissken006

Novice Member
Hi I have a problem with my Sony str-dn1080 audio system using earc. The sound is constantly cutting out. I've tried everything and it won't fix. I'm connected to the sony x900h using hdmi 2.1.from the receivers tv port to the tvs earc port. Both have been updated to latest firmware. My settings are below if it helps, thanks.

Sony str-dn1080

Speaker settings.
Automatic phase matching - auto
Calibration type - engineer

Audio settings
Digital audio linear - auto 1
Sound optimizer - off
Dsd native - off
Pure direct - off
Subwoofer low Pass filter - on
A/V sync - hdmi auto
Dual mono - main
Dynamic range compressor - off
Neural x - off
Sound field - a.f.d as recommended. Tried dolby surround and direct but still the same problem.

HDMI settings
Hdmi 4k scaling - auto
Control for hdmi - on
Standby linked to TV- on
Earc - on
Standby through - off
Audio out - amp
hdmi out b mode - main
hdmi signal format - enhanced

Sony x900h

hdmi signal format - enhanced format
speakers - audio system
audio system prioritisation - on
a/v sync - off
Earc mode - auto
Digital audio out - auto 1
dolby Digital plus output - dolby digital plus
pass through mode - off

If anyone knows how to sort this I'd really appreciate it as I'm having no luck trying to get help from Sony.
 

xSLYx

Active Member
Hi I have a problem with my Sony str-dn1080 audio system using earc. The sound is constantly cutting out. I've tried everything and it won't fix. I'm connected to the sony x900h using hdmi 2.1.from the receivers tv port to the tvs earc port. Both have been updated to latest firmware. My settings are below if it helps, thanks.

Sony str-dn1080

Speaker settings.
Automatic phase matching - auto
Calibration type - engineer

Audio settings
Digital audio linear - auto 1
Sound optimizer - off
Dsd native - off
Pure direct - off
Subwoofer low Pass filter - on
A/V sync - hdmi auto
Dual mono - main
Dynamic range compressor - off
Neural x - off
Sound field - a.f.d as recommended. Tried dolby surround and direct but still the same problem.

HDMI settings
Hdmi 4k scaling - auto
Control for hdmi - on
Standby linked to TV- on
Earc - on
Standby through - off
Audio out - amp
hdmi out b mode - main
hdmi signal format - enhanced

Sony x900h

hdmi signal format - enhanced format
speakers - audio system
audio system prioritisation - on
a/v sync - off
Earc mode - auto
Digital audio out - auto 1
dolby Digital plus output - dolby digital plus
pass through mode - off

If anyone knows how to sort this I'd really appreciate it as I'm having no luck trying to get help from Sony.
Have you tried factory resetting the tv?
My Sony xg950 seemed to be one of the problems with my 1080 have continous sound cut outs, though even now I get sporadic cut outs on the ps5. Not impressed with Sony these days.
 

SnakePlissken006

Novice Member
Have you tried factory resetting the tv?
My Sony xg950 seemed to be one of the problems with my 1080 have continous sound cut outs, though even now I get sporadic cut outs on the ps5. Not impressed with Sony these days.
Hi yeah I'm pretty sure I tried that before. Wouldn't hurt to try again though I suppose. Yeah Sony aren't the greatest. My onkyo receiver was fine. Only upgraded to the sony for earc but the cut outs are too distracting.
 

SnakePlissken006

Novice Member
Thought I'd managed to sort it by switching earc on TV from enhanced to normal but still cuts out. You'd think spending £400 on a receiver that you'd get good quality this is ridiculous. Sony keep trying to tell me its my hdmi cable even though it worked fine on my previous receiver. What a joke.
 

xSLYx

Active Member
Thought I'd managed to sort it by switching earc on TV from enhanced to normal but still cuts out. You'd think spending £400 on a receiver that you'd get good quality this is ridiculous. Sony keep trying to tell me its my hdmi cable even though it worked fine on my previous receiver. What a joke.
The only way I managed to get normal sound without resetting the tv was to press sat/catv on the controller which gave me dolby digital instead of dolby digital plus whilst on the sky box, but then with the ps5 it was still terrible.
No idea why, just seems to be a buggy product, and yeah I'm pssed about spending 400 smackers on it as well, have saved up and looking for a new one.......but they all seem to have a few bugs🤯
Might just wait for the supposedly reliable yammys to come out and hope their worth the dosh.
Have you tried just using an optical cable? Doesn't really help if your using say a ps5 which doesn't use them now, but you might get normal sound through the telly whilst you sort something out.
And if your still under warranty insist that you've got a faulty product and check out legal avenues if they don't change their tune, which I doubt they will. And make sure you say you've tried plenty of cables.
 

The latest video from AVForums

Podcast: Anthem AVM 70 Review, EQing Your Home Cinema Sound System and More...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom