Sony str-dh790

Musicman9

Novice Member
I have recently bought a Sony STR-DH790 receiver. I have a few issues hope someone can help.
Sometimes when playing a dvd the back speakers don't seem to work at all.
I have the 5.1 set up through B&W speakers, the front speakers work ok, occasionally I will get music coming through the back but nothing else.
I have the blu ray dvd player (Sony) attached with the hdmi lead into the back of the receiver. Its connected to the TV (Sony Bravia) (2019 model) via the hdmi ARC (doesn't have eARC) and optical. Also does the same which watching movies on Amazon Prime.

Another problem which I noticed is that the receiver will turn itself on for no reason at all, when this happens the TV doesn't turn itself on. I do not push the remote control or push the button on the front panel. Does it receive a signal from somewhere else and automatically do this?
I wonder if anyone else has encountered this.
Thanks in advance
 

sardas

Novice Member
hello. I also recently bought same avr and connected to my sony xh90 tv. for randomly turning on and off things, I read somewhere to change the following setting from hdmi to serial.
Settings > Remotes & Accessories > RS232C control (Via serial port)

maybe if your tv has similar setting you can give it a try.

for the missing surround sound, did you check if the dvd has 5.1 sound (usually stated on backside of dvd/bluray box). and did you check the received audio signal by "information" button on avr remote? if your avr shows dolby or dts with 5 channels and all 5 speaker names look active (not grayed out) you should get some sound from all of them unless you have physical cable connection problems)
 

Musicman9

Novice Member
Thanks for your reply.
Your comments are interesting, however I have now given up with the inputs to the receiver and put them all back into the TV, and taking the optical OUT from the TV into the optical IN into the receiver. Everything works fine now. Only thing i haven't got is the MENU output from the receiver on to the TV but I can live with that.
I now get full 5.1 surround sound even on Amazon prime where I watch some films.
It has also solved the issue of the receiver turning itself on by itself which was a worry I must admit. The guy I emailed in the Sony shop said he had the same problem but he said it was something to do with the Sky box when it updates it seemingly sends a signal. I don't have a sky box, so didn't follow that up, cause solved the problem, to my satisfaction at least, myself.
 

sardas

Novice Member
Thanks for your reply.
Your comments are interesting, however I have now given up with the inputs to the receiver and put them all back into the TV, and taking the optical OUT from the TV into the optical IN into the receiver. Everything works fine now. Only thing i haven't got is the MENU output from the receiver on to the TV but I can live with that.
I now get full 5.1 surround sound even on Amazon prime where I watch some films.
It has also solved the issue of the receiver turning itself on by itself which was a worry I must admit. The guy I emailed in the Sony shop said he had the same problem but he said it was something to do with the Sky box when it updates it seemingly sends a signal. I don't have a sky box, so didn't follow that up, cause solved the problem, to my satisfaction at least, myself.
if you have a few minutes to check that setting on your tv and "if it was set as hdmi" that might be the source of your problem. I always prefer a healthy arc connection for my sound. and currently it is eARC for me. Also I canceled the option to power up AVR automatically I turn on my TV. I only need avr for movies etc. not regular tv broadcasts. my tv won't turn on my avr. but control it properly after I use on button from avr remote.
 

The latest video from AVForums

Sony Bravia XR A80J OLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom