Sony Sky box crashes when I change channels

Discussion in 'Sky Digital TV Forum' started by Easybourne, Aug 6, 2006.

  1. Easybourne

    Easybourne
    Active Member

    Joined:
    Apr 7, 2005
    Messages:
    249
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Exeter
    Ratings:
    +19
    Hi All,

    Just got a new Sony Sky box after my old Amstrad died a couple of weeks ago. I must say, I'm not overly impressed.

    Every couple of days, the box will crash when changing channels. I get an onscreen message saying "there is a technical fault with this channel". If I change back to the channel I was previously watching, I get the same message on screen. This message will appear on all channels once this has occured.

    The only way to fix it is to unplug the box and restart. This is not as easy as it sounds because the box is plugged in to a 6-way extension behind the TV and tucked under the cabinet!

    Because I can't face calling Sky again and wasting hours of my time and 8p per minute in their appalling customer "service" line, I want you opinions on whether this is somthing that may go away upon the next software update, or should I just get freeview?

    Thanks for your input...
     
  2. SamRadford

    SamRadford
    Well-known Member

    Joined:
    Jul 12, 2005
    Messages:
    3,965
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    103
    Location:
    N. Yorkshire
    Ratings:
    +308
    I don't think so. Sony stopped manufacturing them years ago. I think you got a second-hand one.

    I suggest you buy a more modern Digibox off eBay or from your local paper. You can get a reasonable one for as little as £30.
     
  3. Big Slick KA

    Big Slick KA
    Standard Member

    Joined:
    Apr 14, 2006
    Messages:
    57
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    11
    Ratings:
    +1
    The same happens to my Thompson Sky+ box, I get no response at all from the remote, the only way I can sort it out is to unplug the power cable.

    This is a real pain in the butt if im recording something as its lost along with the power.

    Sigh

    Ah well, nothings perfect :mad:

    BS
     

Share This Page

Loading...