• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Sony RDRHXD970 - dodgy sound thru HDMI

nigeltant

Standard Member
My new machine seems to have problems outputting sound through the HDMI out port, but it seems fine via SCART. I have got it to work intermittantly via HDMI (i.e switch everything off and on again) and I think I have it sorted, but then when I switch the TV from source to source all I get is video and no sound again! It is the same result from DVD or the tuner, so it definitely seems to be the HDMI link that is the problem. Do I send it back??
 

howardg

Standard Member
just an idea - try to reverse the direction of the hdmi cable and make sure the connections are tight. Also check the hdmi settings in the menu you may need to change the audio settings.

By the way where did you buy your 970 from. I got mine from Digital Point and returning items is a real hassle. they dont offer automatic exchange like Amazon.
 

nigeltant

Standard Member
Thanks for the tip, but I did try reversing the cable to no avail! I am now more convinced it is the TV - a Sagem Axium HD-L26-T - which has been a pile of poo anyway (except for the picture quality)! I have now found I can get over the problem by re-selecting the HDMI input if the sound doesn't appear first time - weird! It makes me think that the cable and player are OK after all.
 

nigeltant

Standard Member
...sorry, meant to add I bought it through amazon, but it was a company called pixmania.com who were the suppliers. Only paid £267.49 inc delivery - a bargain I reckon. Received it 2 days after ordering it as well!!!
 

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom