Quantcast

Sony RDR-HXD710 Hard Drive problem

RichyH

Standard Member
I've had this PAL RDR-HXD710 quite a few years now and it's just started exhibiting what looks suspiciously like a Hard Drive problem. Playback of programs from the HD cause the unit to lock up for anything from a few seconds to a few minutes. Picture and sound break up, and transferring the recordings to DVD often fail or work but have stuck audio/picture problems.

The HD was re-formatted (using the in-built 'Format' option) just a few months ago. I suspect the drive is in serious need of defragging and I'm reasonably sure the 'Format' option doesn't do a proper/real wipe. I went as far as taking the drive out and tried to connect it to a PC running Windows 7 and a PC running Ubuntu 11. I think I've ascertained that the drive format is UDF but neither OS would actually read the drive contents. Windows 7 wouldn't even entertain looking at it unless I initialised it (e.g. with an MBR). Ubuntu recognised it was a 160Gb drive and that it was UDF but it couldn't mount it.

Anyway, the HD went back into the Sony hardware and I then tried to access the 'Service Menu' by pressing Power On ("Welcome") and holding down the Rec+Rec Pause+Rec Stop buttons - all of them from the front of the unit. All this did was display the letter 'S' on the front and nothing else happened!

I suspect this might be due to the unit hardly ever (possibly never) having had any updates run on it. It's never been connected up to a good DTV signal, so that side of it has never been used. I checked the settings and I have found the following:

Software version: v1.00.02
Loader version: v1.00.00
Hardware version: B-030-00A-01

Has anyone got any other recommendations as to what I can try? I'm not even sure what options the 'Service Menu' has to offer, but am assuming it might have a few more HD checks and tools?
 

RichyH

Standard Member
Quick update - answered my own question!

'S' is Service Mode but it only outputs via the S-Video port on the back. So, having seen the various options I elected to run a Device Test and then Performance Check. The HDD produces an Error when performing a Sequential Read. I then chose the 'Format' option from within the Service Menu and this took about 9 mins to complete but it formatted OK. However, running the Performance Check again produced an Error (again), so I guess this means I need to buy a new replacement HDD.

As it's a 160GB ATA Seagtae (5400RPM) I might try and upgrade it to a larger drive. I know you have to register the drive's ID via the Service Menu before the 710 can start using it, but that seems like the most likely option I've got.

Has anyone ever upgraded the HDD in the HXD710?
 

RichyH

Standard Member
OK, I have finally found the info on this very forum but it's not exactly easy to find! Looks like the 710 can't be upgraded with a bigger capacity drive, so a straight like-for-like swap is the only option I've got. Oh well, worth a try!
 

timodell

Standard Member
Actually did this successfully, the other day. Tehheads can supply the original fit SATA drive for £22.99 and the fitting is simple. Then use the menu to reload the original O/S and you are all done.
 
Top Bottom