Sony OLEDS dead

fishgeek88

Novice Member
Hopefully someone could help. 3 or 4 months ago my A9G died. One day it was working the next day it would not turn on. No lights, no clicks nothing. Now today a different tv, my A8H in my bedroom is doing the exact same thing. It worked fine last night and now it wont turn on. Any thoughts? Two different rooms two different tvs? Both Sony Oleds...I run a power conditioner and have other sensitive electronics in the house so I doubt its some weird voltage issue with the house. I know these tvs are a few years old but for what I spent on them to have the same issue...Is there any known issues with these?
 

temq

Member
could try a static discharge ,if you have a bad earth etc, unplug tv and hold down physical power off switch if there is one ,for 30 seconds
 

fishgeek88

Novice Member
could try a static discharge ,if you have a bad earth etc, unplug tv and hold down physical power off switch if there is one ,for 30 seconds
That was one of the first things I did
odd question but have to you checked the fuse in the plug?
Ill take a look and see if they have a fuse. I know the A9G has a removable power cord but the A8h is attached to the tv
 

kbfern

Distinguished Member
I thought Sony normally gave 5 yrs with their higher end TV's and even if they don't most of the decent retailers over here give 5 years with most tv's. Where are you from Fish is it the US?
 

The latest video from AVForums

Samsung S95B QD OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom