Sony KD-A85H Audio/Video sync issue

ThorT

Novice Member
I have been struggling with my TV since new with getting audio and video perfectly syncronized.

I think I have tried everything, but can not for the life of me get it quite right. I am my second soundbar now but it is impossible to get it right. The first one was a Sonos ARC and it was just terribly off so it was impossible to watch any program without losing ones sanity. It is better with sound directly from TV, but still slightly off.

Is it just my TV that has this issue? I have tried every setting, reset, new software. Support from Sony etc. It has improved with the latest version, but still off enough that it is irritating to me. I have to add that I am a bit more sensitive about the sync, but I should think a TV with this price tag should work perfectly.

I play mostly from appletv4k as this box has a sync feature that adjust the sound making it slightly better. Directly from android apps it is a bit worse.

Thinking of trying to return the d thing, but i love the picture on it...
 

next010

Distinguished Member
Speakers = Audio System
eARC = Auto
Digital Audio Out = Auto 1
Passthrough = Auto

Those are the settings to enable eARC, make sure firmware on the Sonos ARC is also up to date if you still have it to enable eARC.

Alternatively
Digital Audio Out = PCM

Will only send PCM audio, whether the A85H supports PCM 5.1 audio I do not know (Sonos eARC does) but if not then it would send PCM 2.0 stereo, using PCM might help with sync issues.

If sync issues persist with PCM the only other suggestion I can make is consider a sony brand soundbar, maybe any built in sync compensation only works properly with its own brand hardware.
 

ThorT

Novice Member
Thank you for your reply.

I have tried all those settings.

eARC was set on auto, but the support from the soundbar(Lemus, I returned the Sonos months ago) said to turn it off as it does not support eARC. However there was no difference.

Digital Audio Out set on auto1 does not produce any sound at all, so I have been using PCM.

Passthrough is set to auto, but I have tried off as well.

I was thinking a possibility to adjust sync in the sound bar software would fix this. Sonos had this, but was so far off that I could only get closer but not fix it. But I am a bit bafled that Sony does not know how to produce a TV in 2020 that have syncronized audio/video, and I wonder if it is only my product or others as well? It can off course be a one off model.
 

next010

Distinguished Member
I was thinking a possibility to adjust sync in the sound bar software would fix this. Sonos had this, but was so far off that I could only get closer but not fix it. But I am a bit bafled that Sony does not know how to produce a TV in 2020 that have syncronized audio/video, and I wonder if it is only my product or others as well? It can off course be a one off model.
It's not uncommon as ARC is not a strict standard differences in hardware lead to issues, LG in particular is known for sync issues with Dolby audio.

eARC was supposed to fix this but allegedly it only has audio sync correction for Dolby/DTS 5.1 and nothing else.

As a last ditch effort I'd try a Sony eARC soundbar, if your not getting audio with eARC settings then something is definitely wrong with your TV.
 

The latest video from AVForums

Podcast: Sky Glass, Epson Laser Projectors plus Home Cinema Subwoofers and More…
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom