• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Sony-K502 Receiver

BobAlongTwo

Standard Member
I have a surround system that two surround speakers may or may not work when I turn the TV on. They will turn off after about five minutes run time.

The system is five years old and came as a box system with all matching components. I've changed the front speaker to the surround connections on the receiver and they won't work when I do this.

I've changed the surround speakers to the front connections on the receiver and they will work on the front connections. I use "monster" cables to connect all speaker so I don't think two cables would become defective at the same time.

I have two questions........Does anyone have any suggestions of how to correct this problem?.......And what would be a good system to purchase for "clarity"?

My hearing is starting to slip and I'm hoping clarity in a sound system will help.....

Thank you for your time......And :lease: help!
 
Last edited by a moderator:

davepuma

Distinguished Member
It sounds like a fault with the receiver's rear channels if all the speakers work when connected to the front. If it's old, you might want to weigh up the pros and cons and work out if it will be financially worth repairing. If not, you'll need to set yourself a budget and get out to the dealers and demo. Have you had your hearing checked?
 

The latest video from AVForums

SVS Prime Wireless Pro Powered Speakers - Review Coming Soon
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom