• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Sony HTFS 3 setup problem?

SilvioDante

Standard Member
Hey all,

I am concerned I have not got my system set up correctly and any advice would be greatly appreciated.

I have a Sony Bravia with a Philips DVD (HDMI) an old Sony sky box (not sky+) and of course the HTFS3 2:1 cinema system.

The DVD goes into the processor/Woofer by HDMI
the Sky box goes in on an optical cable (sky box goes to TV on a scart)

The processor goes to the tv from the TV out HDMI to HDMI 1 on the TV

However when switching to the DVD input the system often takes 5 or 6 tries to isolate the input and even then I often get a pink screen or nothing at all . Also using the theatre button (in either DVD input or the optical input) on either the processor remote or the TV remote to make the 'audio system active' results in the same problem.


Can anyone help with this :lease:
 

hildener

Established Member
check your hdmi cables for any possible fault .also check the resolution your dvd player is set to output . i have a sony blu ray player and sony dvd player plus a humax freesat box all connected by hdmi 1.3b cables at 1080i .the system detects the dvd player when a disc is inserted and loads up. all work perfectly.
 

The latest video from AVForums

SVS Prime Wireless Pro Powered Speakers - Review Coming Soon
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom