Sony DVD NS585p fault

Discussion in 'Blu-ray & DVD Players & Recorders' started by garethcymru, Dec 16, 2004.

  1. garethcymru

    garethcymru
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    :thumbsdow Right.. even with the sales looming and most of my money being spent on others (It is xmas after all) I finally decided to upgrade my trusty old Limit 8080 dvd player.. Aside from my Pioneer Laserdisc player the only non Sony piece of kit i don't own.

    After much searching of the forums, and finally finding a mutli-region Sony player with all the necessary outputs (RGB scart, s-video, digital audio out etc.) i decided on the Sony DVP NS585P from Amazon at £89.99.

    But typically upon plugging it in with the nice new shiny Scart leads i'd got from CPC just for this new player... the outsput on my TV was awful.
    And that was just the menu to start with... It was blurry, shadowed and smeary. So right i'll plug in my projector and see what the Svideo output looks like... which was remarkably clear.
    So i changed the scart lead, tried all 3 sockets on my tv and still poor picture. So then i thought i'll try a disc.. star wars episode iv .. text looked poor but not as bad a the menu. Tried a region 1 and a region 3 all loaded ut with poor outputs. (i tried selecteing either video,s-video and RGB)
    then i tried Disc 1 of the Extended Fellowship of the rings R1 which wouldn't even load.

    Am i just unlucky or have i stumbled on an existing problem with my TV rather than the new DVD player.


    My kit consists of

    Sony FX60 Wega 32 100 Htz TV
    Sony DB780 Reciever
    Sony VPL x600 Projector
    Sony SLV SE70 Stereo VCR
    Pioneer CLD-D925 Laserdisc Player
    Panasonic NV-HS800 Stereo VCR

    If anyone can help i'd really appreciate it... i'm trying not to get upset about this... but it sums up my month..

    CHeers
    Gareth
     
  2. Eso

    Eso
    Standard Member

    Joined:
    Nov 29, 2004
    Messages:
    45
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Hello

    I've got the same player as this (got it about a week ago) and the picture on mine is fine. Easily as good as my last 2 Pioneer machines.

    The only problem I am having with mine is that (seems to be only some Region 1 discs) at the top of the screen in both corners the image tends to bend a little - only about an inch or so down the screen, but a bit annoying! Not really so much bending but sorta kinking like the screen is being pushed inwards a little at each side?!

    It's strange because it doesnt seem to do this on Region 2 films, and not on all Region 1 films. It's not my discs as I have tried them elsewhere and they are fine - the DVD players own menu's are not having any problems either!

    I think its some sort of coding problem but in reality I have no idea?!

    As far as your image goes you do have component turned off in the menu and RGB selected right? Also have you checked the switch on the back of the unit is set to standard not progressive?

    Hope you sort this out!
     
  3. garethcymru

    garethcymru
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0

    yeah.. tried turing the progressive on at one point and the screen goes balnk.... also tried 3 scarts on my TV and 3 different scart leads...
    thanks anyway.. checked with amazon but they can't send me a replacement until xmas eve.. for delivery 28th at the earliest!
     

Share This Page

Loading...