Sony DVD DAVS880

Discussion in 'Blu-ray & DVD Players & Recorders' started by richkeys, Jan 20, 2003.

  1. richkeys

    richkeys
    Banned

    Joined:
    Jan 16, 2003
    Messages:
    106
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    19
    Location:
    London UK
    Ratings:
    +0
    Does anyone else have a Sony DAVS880 from www.techtronics.com with the multiregion chip?

    My unit seems to have a problem playing back normal CDs, any ideas?
     
  2. Silent Fly

    Silent Fly
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I heard about this problem before but I cannot remember where... :rolleyes: Sorry
     
  3. letitbleed

    letitbleed
    Active Member

    Joined:
    Nov 5, 2002
    Messages:
    215
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Southampton
    Ratings:
    +4
    I have a multi-region DAVS880 (PRC Direct),I don't have any problems.
    What exactly are the problems you are encountering ?
     
  4. richkeys

    richkeys
    Banned

    Joined:
    Jan 16, 2003
    Messages:
    106
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    19
    Location:
    London UK
    Ratings:
    +0
    it's like when you put a blank CDR in a CD player. It tries to read the disk, you can hear it spin up but then I get just two numbers appear on the display 1 2 and the transport stops working?

    wierd?
     
  5. gsdev

    gsdev
    Standard Member

    Joined:
    Feb 1, 2003
    Messages:
    4
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I had the exact same problem. I sent my unit DAV S550 in for service and only after changing the "DVD PCB Board" the problem was solved. Initially the technician changed the whole drive unit but this did not solve the problem. Only after changing the DVD board the problem was solved.

    Can you check what firmware version you have. You can do this by holding down the STOP & DISPLAY buttons together while turning the volume Knob clockwise.

    On your remote choose 6 (i think) for firmware version.

    To come out of the Eng. Menu, power down the unit.

    Let us know if this is another problem / bug.
     

Share This Page

Loading...