Sony Digital TV picture not stabilising on Digital

H

Heathdavid

Guest
We are on our second new SONY projection TV with built in digital box. On the first set, the picture took 10 minutes before it stabilised on any digital channel, then it was OK on any channel for the rest of the day. It soon took longer to stabilise and was swapped for a replacement set which is exactly the same. It is on a loft aerial which was fine with a previous TV and separate digital box. On digital, the picture stabilises if it has still graphics like film titles - black background and big text - then breaks up on a normal picture.
Analog channels are OK.
Any ideas please?
 

MartinImber

Active Member
Aerial problem - you need an external aerial with CT100 cable.

Sounds like the problems I had originally - fixed by a mast head amp.
 
H

Heathdavid

Guest
Thanks for the ideas. I don't have anything to indicate the signal strength. I had previously used 2 different digital boxes with our old TV and they worked fine.

Someone suggested today that it might need a software update but that is not an option offered on any of the menus! I wonder if that was why COMET are selling them cheap!!
 

MartinImber

Active Member
Selling cheap as it is an oldish model - probably an LCD or DRCMF replacement due out soon

Seen for £1000:eek:

Anyway a cabling or aerial upgrade will help.

You probably have 50Hz first version tuner as used by DX20 and others

New V1.?

Text 2.05
Latest 2.10

ANyway Sony TVs can take an overdriven DTTV signal better than a lot of boxes
 

Similar threads

The latest video from AVForums

Podcast: Samsung HW-Q950T Soundbar Review, Filmmaker Mode, Disney+ $30 for Mulan, AV news and more
Top Bottom