Dismiss Notice
Attention AVForums app / Tapatalk users
Sadly GDPR means that, from 25th, we can no longer offer access to AVForums via the branded app or Tapatalk.
Click here for more information.

Sony Dav Sr1 Problems

Discussion in 'Home Cinema Buying & Building' started by dollby64, Mar 16, 2005.

  1. dollby64

    dollby64
    Standard Member

    Joined:
    Mar 16, 2005
    Messages:
    2
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Has anyone else outhere had problems with their dav sr1.I have had trouble with the picture jumping on scenes. I have had it repaired under warrenty came back just the same[replaced laser].It was replaced with a brand new system with the same problems I have now been told 80% of the dav sr1 sold need an upgrade as sony are aware of the problem and Iam waiting for this to happen.
     
  2. the_apparition

    the_apparition
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi, I have had the DAV SR1 for just over a year now, and last week on my return from holiday, I plugged it in and had no picture.

    I have tried it on other T.V's, with other scart leads, and even tried an old player on my T.V just to make sure it's the DVD player that has the problem.

    I spoke to SONY and as it's a year old and outof guarentee it's basically my problem to get fixed. Has anyone had the same problem or have any suggestions as to what could be the problem.

    Cheers guys, Will.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice