Sony DAV-S550 Help needed!!

Discussion in 'Blu-ray & DVD Players & Recorders' started by richdmx, Nov 17, 2003.

  1. richdmx

    richdmx
    Standard Member

    Joined:
    Dec 27, 2002
    Messages:
    657
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    19
    Location:
    Watford
    Ratings:
    +1
    Hi all,

    My mate just brought a Sony DAV-S550 DVD player and surround set, everything seemed to be ok but when the layer change occurs, the subtitles then appear!

    Does anyone know a fix or a firmware update that might fix this?

    Any help most appreciated!!
     
  2. bonzobanana

    bonzobanana
    Member

    Joined:
    Aug 21, 2001
    Messages:
    3,446
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Yeovil
    Ratings:
    +219
    You could try disconnecting it from the mains for 15 minutes or if you can find the info do a hard reset of the system. Is it multiregion?

    Perhaps the very last 550s have an upgraded firmware and it has introduced this bug. Does it effect all dvds? Are these dvd-rs or original dvds?
     
  3. andy572

    andy572
    Standard Member

    Joined:
    Dec 4, 2002
    Messages:
    361
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Oop North
    Ratings:
    +2
    This was a correctable flaw in (at least) the early players and was, I believe, fixed by a firmware update.

    There'll be loads of mention in the forums from last year...
     

Share This Page

Loading...