Sony CRT 32" - no video/sound, red light.

Discussion in 'General TV Discussions Forum' started by shyamt, Sep 1, 2007.

  1. shyamt

    shyamt
    Standard Member

    Joined:
    Feb 4, 2006
    Messages:
    174
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +2
    My old sony CRT (32") which has worked about 7 years without a problem has stopped working, I'm sorry I don't know model number and don't have manual, but it's fairly old and all of a sudden it stopped working. I get no sound, no picture, just a black screen.

    The red standby light that normally flashes when you change channels still comes up when I press buttons on remote, and also when TV comes on..

    Any ideas on what the problem could be? Thanks!
     
  2. shyamt

    shyamt
    Standard Member

    Joined:
    Feb 4, 2006
    Messages:
    174
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +2
    Found out it's a Trinitron by the way.
     
  3. aekostas

    aekostas
    Active Member

    Joined:
    Jan 2, 2006
    Messages:
    1,263
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    48
    Ratings:
    +52
    The model should feature on the sticker at the back.
     
  4. JayCee

    JayCee
    Distinguished Member

    Joined:
    Jan 20, 2004
    Messages:
    23,764
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    Lanarkshire
    Ratings:
    +2,572
    All Sony models of that vintage are Trinitron...you need to report back with the model no taken from the rear label if you want any sort of meaningful help.
    It'll start with "KV".
     

Share This Page

Loading...