Sony Bravia NX703 Internet Issue - Please Help!

nx703guy

Standard Member
Hopefully somebody can help me, as this has driven me insane! Apologies its a big long but wanted to include as much information as possible.:(

Here’s my problem….
Up until yesterday my TV (KDL-40NX703) had been connecting fine to my home network and internet content was working perfectly. This was up until my ISP had to replace a faulty cable modem. All other wifi devices (2x ipods, 1x Wireless Printer, 1x phone, 4x laptops, 1x PC, 1x Playstation 3) are connecting to the home network with the new modem in place fine and all have no problems connecting to the net.
My current home network configuration is an Ambit Cable Modem with Virgin Media ISP connected via ethernet to a Netgear N300 wireless N router. It is encrypted with WPA-PSK(TKIP)/WPA2-PSK(AES). DHCP is set on and so is UPnP. My router is NOT set to restrict MAC addresses either. My TV is on the PKG4.034EUH-0106 firmware, which sony site says is the latest. I didn’t update so I’m guessing the TV did it on its when the wireless used to work.
This is what I have tried so far. Power cycle TV from energy saving switch, leaving for 10mins turning back on. Restoring TV to factory settings. Soft Reset of TV. Power cycle Cable Modem, power cycle wireless router. Deactivate all other wifi devices in the house. Remove encryption on wireless router. Attempt firmware update on both TV and router (already latest firmware so wouldn’t proceed). Manually assigning subsequent IP address and DNS using the settings from my PC ipconfig
My router is WPS push button and WPS PIN capable. I’ve attempted connecting this way but it times out and is unsuccessful.
On the router side, the TV just doesn’t show up on the list of attached devices. It shows my PC and wifi printer fine.
On the TV when I ask it to scan for networks it finds none, despite the fact there are atleast 12 known networks in my area. When I manually configure the SSID the connection results I get are
CONNECTION RESULTS
Wireless Device: OK
Local Access: Failed
Internet Access: Failed.

The settings that show up when I leave the TV to auto config the IP address etc. in the “View Network Status” are:

Connection Method: Wireless (built-in)
Wireless Device: OK
Network (SSID): NetgearN300
Signal Strength: - (It isn’t showing the signal strength when I leave it to auto config)
Security: WPA-PSK (TKIP)
IP Address Setting: Auto
IP Address: 169.254.196.59
Subnet Mask: 255.255.0.0
Default Gateway: 0.0.0.0
Primary DNS: 194.168.4.100
Secondary DNS: 194.168.8.100
Mac Address: (shown)
Proxy Server: Not Used

When I log into my router it doesn’t show the TV as a connected device. I’m not particularly good at this but I thought the IP address would be in the same range as the other devices on my home network ie: 192.168.1.## and the default gateway: 192.168.1.1 (router)??
I tried to manually assign an IP address of 192.168.1.8 and reserved this and the TV’s MAC address on my router. Then used the settings shown on my ipconfig on my PC, I got a slight improvement and it showed me the signal strength of the network…but still no cheddar and connection results were the same Local Access Failed and Internet Access Failed. Whenever I try to update internet content I get a 2200 error message. I would like to try and connect the TV directly to the router through Ethernet but theres 3 floors in the way and would rather not carry it down!
I've sent a support request to Sony through their website but really don't anticiapte a switft response. If you have ANY suggestions asides from throwing it out the window (that thought had crossed my mind) I’d be very much appreciated!
 

EMANUEL8219

Standard Member
Hi, I am having a simular problem in regards not being able to connect to the wireless via my bravia.

I have a Sony bravia kdl403ex along with the usb dongle to enable a wireless connection. I have cable broadband with virgin, and a apple airport wireless adaptor.

I keep getting

Wireless Device OK
Local Access failed
Internet Access failed

if i connect with just using the ethernet cable it works fine, but this obviously defeats the object of having wireless. Please can someone help me as it is driving me crazy?

:lease:
 

Doctor Hades

Well-known Member
Funnily enough I got my Sony KDL-32EX503 yesterday along with the Sony UWA-BR100 Wi-Fi adaptor. I have a NETGEAR DGND3300v2 router which works fine with my PC (wired) and Xbox 360, PS3 and Wii (wireless) not to mention my parents' laptops (wireless).

However, I just could not get my router to recognise the TV with the Wi-Fi adaptor plugged in at all, although the TV detected my router OK. I added the MAC address of the adaptor, assigned it an IP address as I have for all my devices then finally added it to the list of approved wireless devices. The TV showed in the list but if I switched to another page in the router settings then back it would disappear. Normally my router picks up any wireless devices in range and adds them to a list where you just add them. I'm obviously using a security key and I set the TV's Wi-Fi adaptor up manually as I have done successfully for all my other devices but, nope, it just wasn't working. I was getting the exact same error as EMANUEL8219.

Just when I was beginning to think the adaptor might be faulty (even though it detected my NETGEAR router) I remembered that my router had WPS built-in, although I'd never used it before. I didn't expect it to work but I picked the WPS (button) option and pushed the dome light on my router and to my complete surprise it worked, although it was oddly using the settings I'd already entered manually.

I've absolutely no idea why WPS worked nor why my router failed to detect the Wi-Fi adaptor but I'm just glad that it had WPS. It doesn't help either than the instructions that come with the TV (iManual) and Wi-Fi adaptor are desperately poor either. Honestly, how do Sony expect the average person to set up their TV network when someone experienced like myself was having problems? :facepalm:
 
Last edited:

Doctor Hades

Well-known Member
@nx703guy - Dunno whether this will help or not but have you tried adding the TV's MAC Address to your router, which should then add it as an allowed device, and then assigning it a specific IP address from your router's settings page? I assign a unique IP address to all of my devices from the router so I know which device is connected from the Attached devices page (for some reason my router has a bug where it doesn't display the names I gave each IP address).

Also I set my settings manually for the Wi-Fi adaptor, which didn't work, but when I used WPS they did even though the settings appear to be the same as the ones I entered.
 

nx703guy

Standard Member
Hi Doctor Hades - I've tried adding the TV MAC address under the LAN set up page giving it a reserved IP address. Whenever I try to connect the TV through WPS both the router and TV time out :( I've been going back and forth with SONY tech support and have tried everything possible before they told me to just contact my router manufacturer and ISP.

The TV doesn't seem to detect any wireless networks at all when I press scan, but on the network status page it shows the signal strength of my network. Still doesn't show up on my router though..bizzare!
 

Doctor Hades

Well-known Member
As I mentioned earlier I could only get my TV and router to connect by using WPS because despite the TV detecting my router with a 5/5 strength bar, my router just wouldn't detect the TV at all even while the TV was doing a scan.

That's the first time that has ever happened as normally my router shows any wireless devices that it detects and it's just a case of adding them to the Allowed list and setting an IP address for them.
 

downtick

Standard Member
I have a sony blu ray dvd. I put a new firmware update on it and then got the same problem, the 169.254.xx.xx ip. On mine it comes and goes. Sometimes I get a valid ip from my router but most of the time i get the 169...Even when it works after a few minutes, my internet drops and i am back to the 169 ip...this ip is a private ip that is being given by your TV because your tv is not getting an ip from your dhcp server inside of your router. This usually occurs when the winsock is corrupt. When I scan on blu ray, i see all the networks including mine. It even shows that is connected to my network, however the internet has failed. If i try to re-connect to my router, i then get the 169 ip meaning i do not have a router assigned ip. I can get online with my home pc, my laptop, my wii and my mobile phone all connected to my router, so I know it is not my router in my case. This is for sure not a router issue, but most likely a winsock issue inside of your tv.

It is easy to figure out if it is your router or tv having the problem simply by connecting a computer to your router. If there is no problem with your computer than it is your tv. If your computer has the same issue, then it is your router. I highly doubt it is your router though. Anyway, it is easy to fix on a computer, but on a dvd or tv, I have no idea what to do. I wish I can go back to my old firmware but I cannot. I called sony and am waiting for a call back from a firmware developer sometime today. I am hoping a new firmware version will fix this. As for you, a new firmware is on sony's site as of a few days ago. If you are still having this problem, give it a try and report back if the winsock corruption had fixed or not. Here is the link for your new firmware on sony's site:

Televisions & Home CinemaÂ*|Â* KDL-40NX703Â*|Â*Sony Support Europe

Please let me know if this works or not as I have the same problem as you do, only with a blu ray dvd instead of a tv.
 
Last edited:

nx703guy

Standard Member
@Doctor Hades - Unfortunately my TV or router just don't seem to see each other with WPS and both time out

@Downtick - Tried the new firmware when it came (ironically its meant to fix IPTV connectivity!) but that hasn't worked either! :(

I've sent another query to Sony who seem to have cut n paste their old reply saying contact my router manufacturer or my ISP since it used to work before. With over half a dozen of my own wifi devices able to connect as well as my girlfriends, aswell as I've going through the effort of restoring my network to factory settings and also trying another router lying around, I highly doubt its my router or ISP...
 

downtick

Standard Member
It's not your router or isp, for sure. It's a corrupt winsock file in the tv. It has to be reset and I thought a new firmware upgrade would do it, but I guess not. I have the same problem and if they cannot tell me how to fix it, I will have to buy a new one in the store and just return this one in the box and wait for the next firmware version i guess. No way am I sending this in to sony to get fixed. I got it just over 30 days ago. They have to have a way to reset the winsock as I am sure this happens quite often.
 

downtick

Standard Member
well i spoke to 3rd tier sony support. They told me the firmware up on their site is ruining my model of dvd player as they have had several calls about it. Funny how they still leave the bad firmware version up for the latest download..they are such idiots! they said if you are getting a 169.254.xx.xx ip that your unit is bad and needs to be replaced as there is no way of resetting the winsock on the unit..they should make a new firmware version with this feature built in as i bet there are several tv's and BD's with this problem..so if you see the 169 ip chances are you won't be getting online with it any time soon...Anyway, the idiots wanted me to send it in to a place for repair/replacement...i was like, yea right, its 31 days old and you want me to send it in for repair??? so I did what i said i would do: I went to the store, bought a new one, put the old one in the box and returned it..the new one is working perfectly now..i have the 2nd oldest firmware from last month that i need to install to give me internet content and 3d..after that, no more upgrading the firmware on this BD for me!
 

nx703guy

Standard Member
sad to hear the only solution is a replacement :( i'm still having the connection issues...i'm holding off replacing the tv as i have a five year warantee with john lewis, which will hopefully cover it should sony not fix the problem, cos i've heard the 40nx7 can be really hit or miss with coning etc and my set seems to b ok and don't want to trade it for a dud..
 

The latest video from AVForums

The Best Movies and TV Shows Coming to Netflix in November 2020: Tom's Thumbs.
Top Bottom