Sony BDP-S570 BD, Sony STR-DH810 AVR & Panasonic TH37-PX80B Plasma - handshake issue

Discussion in 'Blu-ray & DVD Players & Recorders' started by Hepps, Jan 9, 2012.

  1. Hepps

    Hepps
    Active Member

    Joined:
    Oct 3, 2011
    Messages:
    150
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +17
    I have a Sony blu ray player, connected via a Sony AVR and Audioquest Pearl HDMIs the long one is 8m) to a Panasonic 37 inch plasma.

    The problem is an intermittent loss of picture. The sound continues but the screen goes black. If I press pause and then play again it usually sorts the picture out again. Usually happens two or three times in a movie and drives me (and the kids) nuts.

    The same blu ray player worked fine when directly connected to the same plasma TV, but that is not an option now due to my set up via the newest bit of kit, the Sony AVR.

    I suspect this is a dreaded "handshake" issue. But I have no idea what, if anything I can do about it.

    Any ideas gratefully received ?

    Thanks in advance,

    Hepps
     
  2. Hepps

    Hepps
    Active Member

    Joined:
    Oct 3, 2011
    Messages:
    150
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +17
    Anyone ?

    Thx
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice