Sony BDP-S3200

BlueScreen92

Novice Member
To whom it may concern,

I have recently got a "new" Blu-Ray player (its make and model are in the title of this thread), and I'm having trouble with getting the thing to eject its disc tray. I have tried the following:

  • [Stop], [Home], [Top Menu] (only says it's unlocked, but doesn't really unlock it)
  • Holding down [Eject] on the player while plugging it in (ejects and subsequently closes tray, spamming eject key on system boot sometimes works]
  • Resetting player to factory settings (didn't do much good)
  • Updating system software (fails every time I try)
So, here I stand with what would be a dead paperweight, unless I can figure out how to get this fixed, or at least enter the service menu. So, here I am, looking to the community for help, which would be gladly appreciated.
 

BlueScreen92

Novice Member
Update: I forgot to mention that I have also tried to disable a so-called "Demo Mode" by holding down the [Eject] and [Power] buttons on the player, but to no avail.
 

The latest video from AVForums

Prey + Bullet Train reviews, Heat 4K + Event Horizon 4K and all the latest movies and TV news
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom