Sony A90J OLED Owners and Discussion Thread

IL Cattivo

Distinguished Member
So has everyone applied this recent Firmware update for the A90J as my set keeps prompting me to apply it for a few weeks now.

Can't remember what exactly it improves?
 

San5324

Active Member
So has everyone applied this recent Firmware update for the A90J as my set keeps prompting me to apply it for a few weeks now.

Can't remember what exactly it improves?
I also finally did it because I would like to have the same as in Andy his post (little bit higher).

Mine deff don't say that and have no idea what has been added.. I checked the update notes before downloading it but that also didn't showed a lot.
 

supermariojj

Active Member
Just got my new XR-55 A90J from Sony which replaces the A1 which suffered from dreaded colour stain in the middle of the screen, under the 5 year guarantee. Lets hope i have better luck with this one.
 

GAmbrose

Well-known Member
I also finally did it because I would like to have the same as in Andy his post (little bit higher).

Mine deff don't say that and have no idea what has been added.. I checked the update notes before downloading it but that also didn't showed a lot.

The last one was something about Android HD+ apps in Germany.
 

micks_address

Well-known Member
Hi folks,
On the in built in apps I'm getting audio issues recently. When watching Netflix etc I get no audio to my receiver for about ten seconds of each episode then it kicks in.
Anyone have anything similar?
Cheers,
Mick
 

micks_address

Well-known Member

Barney Gumble

Well-known Member
Hi folks,
On the in built in apps I'm getting audio issues recently. When watching Netflix etc I get no audio to my receiver for about ten seconds of each episode then it kicks in.
Anyone have anything similar?
Cheers,
Mick
Morning Mick,

I get the same delay, it seems to take an age for sound to filter through to the receiver. And I get that delay from both the TV's built-in apps, as well as the PlayStation, Reavon and Sky Q.

I have exactly the same set-up as you, TV and receiver but, for me, the problem is short term... both the A90J and the A2A are being collected from RS and I'm getting something else.

I've a fire cube connected to the receiver directly and that doesn't suffer the same delay.
 

Mallett94

Distinguished Member
Morning Mick,

I get the same delay, it seems to take an age for sound to filter through to the receiver. And I get that delay from both the TV's built-in apps, as well as the PlayStation, Reavon and Sky Q.

I have exactly the same set-up as you, TV and receiver but, for me, the problem is short term... both the A90J and the A2A are being collected from RS and I'm getting something else.

I've a fire cube connected to the receiver directly and that doesn't suffer the same delay.
What are you getting instead? Are you selling them back to RS or returning them as faulty under warranty?
 

Barney Gumble

Well-known Member
What are you getting instead? Are you selling them back to RS or returning them as faulty under warranty?
The A90J is faulty and is being replaced with a different TV, the A2A was always due to be returned and replaced with an A4A but, seeing as RS are coming to my home to collect the A90J and mount a new TV, I've asked they take the A2A away too until such time they get stock of the A4A.

The A4A's have been due in October, but there's no sign of them yet. I'll manage without using my speaker arrangement in the short term.
 

Barney Gumble

Well-known Member
What fault did your A90J have Barney? You might have already mentioned it so apologies.
I didn't mention it chap. It has lost the ability to remember devices connected. As such, HDMI control and ARC don't work. Normally, all device tabs are colour and labelled as to what they are, mine are now black and just labelled as HDMI 1, 2 etc.

I get picture, but only sound via the TV's built-in speakers, nothing to the receiver. And it doesn't remember any of my personal setting adjustments to the presets. Each day I've turned it on for the past near month, I have to adjust the 'custom' preset for each input to my taste.

Sony have concluded it is faulty, RS have graciously offered me my choice of a replacement.

I am not going to bad mouth the A90J more than I have already in this thread. I know many, if not all of you, haven't shared my experience and are happy with your TVs. More power to you and long may that continue:thumbsup:.

I think it's time for me to try something new:).

Edit; Mick's problem that I can relate to, was prior to this latest and terminal issue.
 

Mallett94

Distinguished Member
I didn't mention it chap. It has lost the ability to remember devices connected. As such, HDMI control and ARC don't work. Normally, all device tabs are colour and labelled as to what they are, mine are now black and just labelled as HDMI 1, 2 etc.

I get picture, but only sound via the TV's built-in speakers, nothing to the receiver. And it doesn't remember any of my personal setting adjustments to the presets. Each day I've turned it on for the past near month, I have to adjust the 'custom' preset for each input to my taste.

Sony have concluded it is faulty, RS have graciously offered me my choice of a replacement.

I am not going to bad mouth the A90J more than I have already in this thread. I know many, if not all of you, haven't shared my experience and are happy with your TVs. More power to you and long may that continue:thumbsup:.

I think it's time for me to try something new:).

Edit; Mick's problem that I can relate to, was prior to this latest and terminal issue.

What do you think you are going to go for? Are you sticking with OLED or going to try and top end FALD LED LCD? Does the built in Smart OS matter to you or do you think you will move to using a dedicated streaming box i.e. Apple TV 4K or something like that?
 

Barney Gumble

Well-known Member
What do you think you are going to go for? Are you sticking with OLED or going to try and top end FALD LED LCD? Does the built in Smart OS matter to you or do you think you will move to using a dedicated streaming box i.e. Apple TV 4K or something like that?
Oh I don't think I could ever go back to LCD LED, not after three OLEDs;).

RS are bringing me a JZ2000.

I borrowed back my fire cube from my dad, but I'll likely give it back to him once I've familiarised myself with the TV's built-in apps, to see how they perform in comparison.

I tried everything I know to try and resolve the issue, resetting every device, including the receiver, as well as reseating all HDMI leads, even trying different ones. And then I tried everything Sony asked of me, with no joy.
 

IL Cattivo

Distinguished Member
@Barney Gumble Not tempted by Sky Glass then mate? :rotfl:

<hides for cover> :D
 

micks_address

Well-known Member
Morning Mick,

I get the same delay, it seems to take an age for sound to filter through to the receiver. And I get that delay from both the TV's built-in apps, as well as the PlayStation, Reavon and Sky Q.

I have exactly the same set-up as you, TV and receiver but, for me, the problem is short term... both the A90J and the A2A are being collected from RS and I'm getting something else.

I've a fire cube connected to the receiver directly and that doesn't suffer the same delay.
Hi Barney is it only since last firmware update the issue appeared for you?
 

Barney Gumble

Well-known Member
Hi Barney is it only since last firmware update the issue appeared for you?
I believe so.

Not long after that, my TV failed altogether. I'm not saying it's related, I'm just unable to offer more insight on your problem mate, sorry.

Edit; I assumed you meant the last TV update BTW. The A2A hasn't had one since August.
 

micks_address

Well-known Member
I believe so.

Not long after that, my TV failed altogether. I'm not saying it's related, I'm just unable to offer more insight on your problem mate, sorry.

Edit; I assumed you meant the last TV update BTW. The A2A hasn't had one since August.
Yes the tv update, I'm tempted to do a factory reset of the tv to see if it helps
 

IL Cattivo

Distinguished Member
I saw that the latest fw update for the A90J was related to some German apps, so have never bothered applying it.

If it ain't broke... don't fix it.
 

Barney Gumble

Well-known Member
I saw that the latest fw update for the A90J was related to some German apps, so have never bothered applying it.

If it ain't broke... don't fix it.
There's normally more to the updates than they make publicly available.

Certainly with LG, they'll list very little info on the update notes but, there's always some clever so and so over on AVS that has gleamed more information on what is contained therein.

I think manufacturers don't trust the end-user to maybe understand all the technical details or maybe feel they/we don't need to know🤷‍♂️.
 

The latest video from AVForums

Sony Bravia XR A80J OLED TV Review
Subscribe to our YouTube channel

Latest News

Microsoft to acquire Activision Blizzard for $70 billion
  • By Andy Bassett
  • Published
Cyrus Audio joins BluOS Audio Ecosystem
  • By Andy Bassett
  • Published
Audio Pro expands C10 MkII speaker range with new colours
  • By Andy Bassett
  • Published
BBC licence fee to be scrapped in 2027
  • By Andy Bassett
  • Published
What's new on Netflix UK for February 2022
  • By Andy Bassett
  • Published
Support AVForums with Patreon

Top Bottom