Sony A500 - Teleconverter - 'no lens fitted'

cheapaschips1

Standard Member
Hi, all,
In a fit of pique (and against the advice of shokotan) i bid and won a teleconverter on Fleabay for my sony A500
it's a teleplus M-AFi 2x MC4 (well that's what it says on the side)
the guy who was selling it did say he had issues with it autofocusing at full zoom so it was spares or repairs. it wasnt too dear and i did get the bidding red mist and ended up winning it. (when i really want to win something, i usually dip out and lose).
anyway - when i fit it the problem is with a lens fitted and i depress the fire button it says no lens attached - shutter is locked or something like.
does anyone have any idea if -
1 - it's the T/C just isnt compatible
2 - the T/C is probably Broken
3 - There's a setting you can change to get it to work
4 - you can get it chipped to work
(My camera is at firmware rev 1)

Much appreciate any thoughts
 

shotokan101

Distinguished Member
"Told You So" :D :p :devil: ;)

Check the TC - see how many electrical contactes it has - shoudl be either 5 (likely on an older TC) or 8 - then check the lens - check how many contacts - if lens has 8 then......probaly the cause of your issue.... so if you have any oither lense then see if you have one with 5 pins and try it :)

...and if you don't have any lenses with 5 pins - I'll sell you one :rotfl:

Jim
 

cheapaschips1

Standard Member
I've had a look at that thread and it suddenly clicked about stopping down.
i was trying it with a tamron 70-300 lens.1:4-5.6
swapped over to my 50mm F1.7 prime and it worked fine.
it also worked fine with my 35-70 mini beercan. the macro function is improved quite a lot. i took a piccie of a 5p with and without the T/C and with it, the detail was much improved.

I actually bought it to try out with a sigma 400 prime (when it arrives) when i go birding.
any thoughts on what my limitations are?
i get the stoppnig dow nthing, but my head stops at the general principle and cant get to the point of working out exact numbers.
if i go out in blazing light, is there any chance it will work ?

cheers
 

shotokan101

Distinguished Member
AF is not guaranteed higher than F5.6 and a 2x TC adds 2 F stops so if you do the math then you need to be shooting at F2.8......

JIm
 

Pirate!!

Banned
Ahoy!

A TC will only work in AF mode with lenses of F/4, F/2.8, F/1.8 and F/1.7 (or not exceeding F/4 - ie; F/4-5.6 for example) on the Sony mount else you change to manual mode. If the lens and TC have 8 contacts, then you'll retain the ADI metering flash function, though this only works if the flash is pointing directly ahead else it reverts to TTL if using an external gun pointing upwards or sideways for example. If the TC has 5 contacts, then you'll only have TTL metering.

A 1.4x TC reduces light by 1 stop (so F/4 becomes F/5.6) and a 2x TC by 2 stops (F/4 becomes F/8) and you'll likely find the AF much slower with a TC attached. If you need the extra length, I suggest you get something like my Sigma AF 100-300mm F4 EX DG (IF) APO or a Minolta AF 300mm F4 APO HS G unless you can afford something like my Tamron SP 70-200mm F/2.8 AF LD Di Macro or the Sigma 70-200mm F/2.8 equivalent.

A 2x TC on a 70-200mm F/2.8 lens @ 200mm will become an F/5.6 400mm and a 1.4x TC on a 70-200mm F/2.8 lens @ 200mm becomes an F/4 280mm.

A TC is wasted otherwise, though if you have a Tamron SP 90mm AF F/2.8 1:1 Di Macro and clipped on a 1.4x or 2x TC, I would think the resulting macro's would be both HUGE and very detailed.

Hope this helps unless I've missed something or am talking complete hairy danglers.
 

cheapaschips1

Standard Member
Pirate,
thanks, yes it makes sense. The only thing i cant work out is why my tamron wont have a bar of it. even in manual mode
I've had a trawl on fleabay at the types of lenses you mentioned...whe you get down the stops nothing is that cheap is it - is that you're two sigmas ?
I might have to save up a while unless i want to seriously upset the wife. V nice lenses though.
Thanks again
 

Pirate!!

Banned
Pirate,
thanks, yes it makes sense. The only thing i cant work out is why my tamron wont have a bar of it. even in manual mode
I've had a trawl on fleabay at the types of lenses you mentioned...whe you get down the stops nothing is that cheap is it - is that you're two sigmas ?
I might have to save up a while unless i want to seriously upset the wife. V nice lenses though.
Thanks again
What bar are you referring to with the Tamron?
 
Last edited:

cheapaschips1

Standard Member
'won't have a bar of it' , is a phrase we use in the midlands. it means it just wont work at all.
i thought that perhaps the tamorn would work at the 70mm end of the range as that should handle F4, but clearly it wont handshake with the converter if any of the range is outside F4
 

shotokan101

Distinguished Member
'won't have a bar of it' , is a phrase we use in the midlands. it means it just wont work at all.
i thought that perhaps the tamorn would work at the 70mm end of the range as that should handle F4, but clearly it wont handshake with the converter if any of the range is outside F4
I think your forgetting perhaps my earlier points about the number of connections ?

If it's a modern Tamron it will have 8 and your TC probably has 5 - or have you managed to get it working with another 8 connection lens ?

Also F4 after losing 2 stops won't AF.... as I posted earlier it would need to be F2.8 or less....

Jim
 

Trending threads

Top Bottom