• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Sony A1E Extremely Slow!

Hamsnacks

Novice Member
Recently purchased a 65" Sony A1E OLED, great looking TV and the quality is fantastic, however the Home Page/Android system is extremely slow, like to the point I'd be willing to return it and buy an LG or Samsung. Took the Sony over the LG because everyone said the Processor was more superior.

Upgraded from a 2013 PN60F8500 and I'd take the speed and smoothness of the Plasma's system any day.

Strolling up and down through the page is so laggy, increasing the volume is a second or two delayed, apps are so slow I'd rather not use them and just overall so frustrating to use when you consider the price and technology of this TV.

Anyone else experiencing the same thing, is this a common issue with the Android TV or do I maybe have a defective unit? All updates have been installed.

Thanks
 

mark800

Distinguished Member
Recently purchased a 65" Sony A1E OLED, great looking TV and the quality is fantastic, however the Home Page/Android system is extremely slow, like to the point I'd be willing to return it and buy an LG or Samsung. Took the Sony over the LG because everyone said the Processor was more superior.

Upgraded from a 2013 PN60F8500 and I'd take the speed and smoothness of the Plasma's system any day.

Strolling up and down through the page is so laggy, increasing the volume is a second or two delayed, apps are so slow I'd rather not use them and just overall so frustrating to use when you consider the price and technology of this TV.

Anyone else experiencing the same thing, is this a common issue with the Android TV or do I maybe have a defective unit? All updates have been installed.

Thanks
The remote is a bit funny as in you have to point it accurately. I've not come across an issue with the volume being delayed.
When you updated the TV firmware, did you do a reset?
Has this slowness come on, or are you saying it is always like that?
Did it come on with the new firmware?
Have you tried resetting the TV after experiencing the problems?
 

Nicholars

Banned
Android on Sony is most definitely not the fastest OS out of the different brands! They will update to Android Nougat which might be better.
 

GadgetObsessed

Prominent Member
The Sony has a great processor for picture processing but the Android implementation by Sony isnt great. (I have a ZD9 which has the same processor as the A1.)

Personally, I don't use the smart features on the TV and instead use an external device. In my case I have either a Sony X800 UHD player (which I paid £300 for from Power Direct) or an XBox One S. (about £230)

The X800 is faster than the TV.
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom