1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sony 930 Volume led Dead.

Discussion in 'AV Receivers & Amplifiers' started by michaelm, Mar 16, 2002.

Tags:
  1. michaelm

    michaelm
    Banned

    Joined:
    Aug 13, 2001
    Messages:
    678
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Belfast
    Ratings:
    +2
    My volume control led has gone out on my Sony Strdb930 receiver(without warning, no dimming).

    Can I install another one myself or does it need a visit to the amp doctor?
     
  2. mjn

    mjn
    Distinguished Member

    Joined:
    May 24, 2001
    Messages:
    17,955
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    Herts, England
    Ratings:
    +4,932
    never taken one apart myself, but it can't be that hard. Plus i believe the repairs on Sony hi-fi equipment is quite high.!
     
  3. Steve T

    Steve T
    Active Member

    Joined:
    Aug 30, 2000
    Messages:
    438
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Redditch
    Ratings:
    +3
    I had the same problem with mine about 12 months ago (predictably 3 weeks outside the 1 year warranty...) You may find that it leads to the remote not being able to control the volume at all in a few weeks - this is what happened to me, and is a lot more inconvenient than just the LED going.

    Took it to a repair centre and I think it was cost about £28 for the repair. However, I contacted Sony explaining that it was only 3 weeks outside warranty and blah blah blah. Most helpfully, they sent me a cheque for the full amount of the repair.

    That's what I call a result - full marks to Sony customer services!
     

Share This Page

Loading...