Sony 4k TV displaying as 1080p in windows 10

brrbevil

Standard Member
I had to make a custom setting to get 1440p to work in Cyberpunk.
That's interesting. I did just try to create a custom resolution of 3840 x 2160 at 60hz, but it just said I already have that as an option so I couldn't create anything. According to specs, my TV can't do 4k at 120hz, so I'm not trying that. I'm just at a loss why windows won't read my display as native 4k.
 

next010

Distinguished Member
That's interesting. I did just try to create a custom resolution of 3840 x 2160 at 60hz, but it just said I already have that as an option so I couldn't create anything. According to specs, my TV can't do 4k at 120hz, so I'm not trying that. I'm just at a loss why windows won't read my display as native 4k.

Using CRU as I outlined or using Nvidia custom ?
 

huxley

Member
That's interesting. I did just try to create a custom resolution of 3840 x 2160 at 60hz, but it just said I already have that as an option so I couldn't create anything. According to specs, my TV can't do 4k at 120hz, so I'm not trying that. I'm just at a loss why windows won't read my display as native 4k.
I had to trick it into letting me save it. I had my screen set to 1080p at the time, when i set the custom resolution to 1440p I told it I wanted 30hz and just changed that after.
 

brrbevil

Standard Member
Do you have anything else that outputs 4K video, at least that would tell you if its the TV or the PC.

You could try messing with the CRU but that can be complicated but perhaps it can correct something wrong in the EDID.
  • Set your desktop res to 3840x2160 60Hz
  • Run the software and on its main screen you should see a detail resolution section with the 3840x2160 60Hz res listed, select that resolution and click on edit
  • Under Timing from the menu select "Automatic HDTV"
  • Hit okay then okay again to close the software
  • Run restart (32-bit OS) or restart 64 (64-bit OS) to apply the change.

If nothing changes go into resolution section of GPU driver and select the 2160p 59hz output if thats there instead of 60Hz.
So I ran the CRU utility while in 3840x2160 60hz on my desktop, but I'm not seeing 3840x2160 resolution to select in the CRU utility. Am I missing something?

1612364000862.png
 

Cha1ky

Distinguished Member
Could it possibly be the cable your using? A very old HDMI that perhaps doesn't do 4K 60?
 

brrbevil

Standard Member
Could it possibly be the cable your using? A very old HDMI that perhaps doesn't do 4K 60?
Nope, I just recently went out and bought a HDMI cable rated up to 48 GBs and 8k in the process of diagnosing this issue, just to rule this out for sure.
 

next010

Distinguished Member
So I ran the CRU utility while in 3840x2160 60hz on my desktop, but I'm not seeing 3840x2160 resolution to select in the CRU utility. Am I missing something?

View attachment 1453755
Yeah that's weird it should be 3840x2160 under detailed resolutions.

Under extension blocks select that entry then click on edit then select Tv resolutions and click edit again it should list all supported resolutions of the TV, don't make any alterations but check if 2160p 60hz is there.

If you want to try overriding whatever windows/nvidia is detecting as 2160p 60hz then try this.

Set your desktop to 1080p 60hz first.
Run CRU
Select add from the detailed resolutions section
timing menu select "automatic HDTV"
horizontal = 3840
vertical = 2160
frequency = leave as is

Hit okay to close then again to close the program and run the restart tool for whichever version OS you have. Now try applying the 2160p resolution.

If that doesn't correct it I'd suggest asking over on the forum of CRU, they may know better.

The only other suggestion I can make is boot into windows safe mode and delete all of the monitors listed under device manager and uninstall nvidia driver and boot back into normal windows and reinstall nvidia driver.
 

brrbevil

Standard Member
Yeah that's weird it should be 3840x2160 under detailed resolutions.

Under extension blocks select that entry then click on edit then select Tv resolutions and click edit again it should list all supported resolutions of the TV, don't make any alterations but check if 2160p 60hz is there.

If you want to try overriding whatever windows/nvidia is detecting as 2160p 60hz then try this.

Set your desktop to 1080p 60hz first.
Run CRU
Select add from the detailed resolutions section
timing menu select "automatic HDTV"
horizontal = 3840
vertical = 2160
frequency = leave as is

Hit okay to close then again to close the program and run the restart tool for whichever version OS you have. Now try applying the 2160p resolution.

If that doesn't correct it I'd suggest asking over on the forum of CRU, they may know better.

The only other suggestion I can make is boot into windows safe mode and delete all of the monitors listed under device manager and uninstall nvidia driver and boot back into normal windows and reinstall nvidia driver.
So I ran the CRU again and checked under extension blocks and TV resolutions and 3840 x 2160 at 60hz was listed there. I then proceeded to add 3840 x 2160 under detailed resolutions after selecting automatic HDTV as you suggested and exited out of the program by hitting ok a couple of times. After a computer restart, the resolutions offered have changed slightly in NVIDIA control panel (I can still select 3840 x 2160 though), but it's still reading 1080p as native.

I haven't tried booting into safe mode and deleting monitors/GPU drivers yet, but I will mess around with that this weekend. Honestly, the refresh rate dropping suddenly (at least that's what it appears to be) where the screen becomes very choppy is honestly the most annoying thing for me, where I have to exit out of whatever I'm doing and set 1080p again to fix before going back to 4k. I have used this TV for 4-5 years as a PC monitor at 1080p previously, and never had an issue with it until trying to go 4k and staying in 4k. It's very frustrating as according to specs it should be a capable native 4k monitor.

Anyways, I appreciate all the help in this thread. I may just end up just having to get a new screen so I have peace of mind, as I know that 1080p issue is going to bug me, as after spending way too much on my new PC build, I definitely want to be able to game in 4k without any issues.
 

richardb70

Distinguished Member
What's Sony saying? Anything helpful?
 

brrbevil

Standard Member
What's Sony saying? Anything helpful?
I haven't contacted them yet. I have a sneaking suspicion they aren't going to be very helpful, as I'm sure all of their tech support is just contracted out to the cheapest party, but I will try contacting them soon to see what they have to say.
 

richardb70

Distinguished Member
I would. The "native" thing isn't right at all. Wonder if there's a firmware update on your TV that would address it?
 

brrbevil

Standard Member
I would. The "native" thing isn't right at all. Wonder if there's a firmware update on your TV that would address it?
I did update to the latest firmware, and checked it in the actual TV settings to confirm that the firmware updated properly. Also, for my particular TV, the latest firmware added "enhanced" settings on all the HDMI ports to allow 3840 x 2160 at 60hz according to the firmware notes, and I am able to select enhanced for all the HDMI ports in settings, so that's a pretty good indicator the latest firmware did install correctly.
 

brrbevil

Standard Member
So did this get solved?
Not yet. I talked to a "representative" at Sony who were not all that helpful, but he thought it might have something to do with the A/V receiver since my TV does have ARC (audio return) and I use that with my receiver. Thus, even though I have my PC plugged directly into my TV, the ARC is still sending a signal to the receiver which may be distorting the signal somehow.

I have completely disconnected my receiver, and I haven't noticed the flickering I was getting at least, although it hasn't been that long so we'll see if it solved that issue. My native resolution is still reading 1080p in windows.

I am going to delete my monitor/GPU in windows 10 and completely re-install here soon, with the A/V receiver completely disconnected from TV, as my initial setup with monitor/GPU was with receiver connected. Hoping this fixes my native resolution issue, but we'll see. I have been extremely busy with work for the past few days, so I haven't gotten around to it yet, but will report back here when I do.

Also, the rep thought it was interesting that windows was reading my Sony TV has Sony TV(02). I do have a Sony receiver as well, and since when I initially installed my TV in windows 10, it was plugged into the receiver, he was thinking that somehow the receiver was installed as TV(01) and caused my actual TV to get installed as (02) which could be screwing things up. Regardless, doing a fresh install of monitor/GPU should fix this issue if this is indeed the cause.
 
Last edited:

brrbevil

Standard Member
Yeah that's weird it should be 3840x2160 under detailed resolutions.

Under extension blocks select that entry then click on edit then select Tv resolutions and click edit again it should list all supported resolutions of the TV, don't make any alterations but check if 2160p 60hz is there.

If you want to try overriding whatever windows/nvidia is detecting as 2160p 60hz then try this.

Set your desktop to 1080p 60hz first.
Run CRU
Select add from the detailed resolutions section
timing menu select "automatic HDTV"
horizontal = 3840
vertical = 2160
frequency = leave as is

Hit okay to close then again to close the program and run the restart tool for whichever version OS you have. Now try applying the 2160p resolution.

If that doesn't correct it I'd suggest asking over on the forum of CRU, they may know better.

The only other suggestion I can make is boot into windows safe mode and delete all of the monitors listed under device manager and uninstall nvidia driver and boot back into normal windows and reinstall nvidia driver.
Keep us posted. Best of luck.
So, I was wrong thinking that might be the receiver plugged into the audio return channel potentially effecting the signal somehow and causing the flickering. I just got the random flickering again in which I had to go back down to 1080p to fix then back up to 4k again.

Also, I did finally get around to deleting monitor and uninstalling NVIDIA control panel, and then doing a fresh reinstall on both (with receiver completely unplugged from TV), and that did nothing to fix the issue. Windows is still reading my TV as native 1080p when its supposed to be a capable 4k TV per specs.

I'm really at a loss. I think at this point I may just have to spring for another TV to do my gaming and using this Sony TV I have now for work purposes only. It's money I don't really want to spend, but I don't see any other option at this point. Either this TV really isn't capable of the specs being promoted by Sony, or I have a faulty unit somehow.
 

next010

Distinguished Member
So, I was wrong thinking that might be the receiver plugged into the audio return channel potentially effecting the signal somehow and causing the flickering. I just got the random flickering again in which I had to go back down to 1080p to fix then back up to 4k again.

Also, I did finally get around to deleting monitor and uninstalling NVIDIA control panel, and then doing a fresh reinstall on both (with receiver completely unplugged from TV), and that did nothing to fix the issue. Windows is still reading my TV as native 1080p when its supposed to be a capable 4k TV per specs.

I'm really at a loss. I think at this point I may just have to spring for another TV to do my gaming and using this Sony TV I have now for work purposes only. It's money I don't really want to spend, but I don't see any other option at this point. Either this TV really isn't capable of the specs being promoted by Sony, or I have a faulty unit somehow.

I would purchase something cheap like Amazon FireTV stick 4K and see if you can actually output normal 4K video to the TV to rule out the PC, if it still looks bad and flickers then I'd suspect the TV is faulty.
 

brrbevil

Standard Member
I would purchase something cheap like Amazon FireTV stick 4K and see if you can actually output normal 4K video to the TV to rule out the PC, if it still looks bad and flickers then I'd suspect the TV is faulty.
I do have a roku ultra that I bought 6 months ago that is capable of 4K, I just don’t know how to tell what resolution the tv is displaying the content at when using the roku. I mean I can’t “set” the resolution like I can in windows to test 4K. I have never had any flickering issues with the roku but I might not be watching 4K content either.
 

sykotik

Distinguished Member
I do have a roku ultra that I bought 6 months ago that is capable of 4K, I just don’t know how to tell what resolution the tv is displaying the content at when using the roku. I mean I can’t “set” the resolution like I can in windows to test 4K. I have never had any flickering issues with the roku but I might not be watching 4K content either.
The gf has my roku and if the TV is 4k uhd it will give me the option for 4k 50hz or 4k 60hz , so if yours gives you that option then you'll know that the TV can do 4k or not .
 

brrbevil

Standard Member
The gf has my roku and if the TV is 4k uhd it will give me the option for 4k 50hz or 4k 60hz , so if yours gives you that option then you'll know that the TV can do 4k or not .
Ok, I messed around with the settings on my Roku a bit and found the setting where it tests my display to see what it's capable of displaying. The Roku test is saying my TV is 4k capable at 60hz, but said it was not HDR capable (which I don't think is a surprise as this model doesn't have HDR I don't think). So I have the Roku set at 4k 60hz UHD now, as before it was just set to automatic. I'll see if I get any flickering or notice any issues when using the Roku on this setting.
 

brrbevil

Standard Member
I just wanted to give an update here. I think its definitely the TV that is having the issues, as the flickering problem I have described seems to strictly be a TV issue. I have found that I don't need to go down to 1080p to fix the flickering (which I usually get about twice per day) and just turning off the TV and turning it back on seems to fix the problem. This seems to point to the TV solely as the culprit.

So far I haven't noticed any issues with using the Roku set on 4k, although I don't really watch much 4k content so I'm not sure this is actually means anything. I mainly watch my own personal library I have on Plex, which is pretty much all 1080p content.
 

The latest video from AVForums

Podcast: LG C1 OLED + JBL Synthesis SDR-35 First Thoughts, plus TV Show & Disc Reviews & more
Subscribe to our YouTube channel

Latest News

What's new on UK streaming services for June 2021
  • By Andy Bassett
  • Published
Austrian Audio launches Hi-X65 headphones
  • By Andy Bassett
  • Published
Roku expands streaming content with Roku Originals
  • By Andy Bassett
  • Published
What's new on Netflix UK for June 2021
  • By Andy Bassett
  • Published
AVForums Podcast: 12th May 2021
  • By Phil Hinton
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom