Sonicstage 2.3 not recognising mp3's



I'm bemused. Over the past year I've ripped hundreds od cd's using EAC and all play & work fine on IPOd's, PC's, and various pieces od software. I now have a HD3 and Sonicstage 2.3. When I import all these mp3's SonicStage reads all the tags etc. OK but won't recogise the occasional track(about 1 in 100) as an mp3, but will happily play it. This results in the album not being stored by the tags of the tracks it contains, but in a group at the end, with all the other albums, with misread tracks, with no artist. Also if i re-rip the track, then re-import it, the problem isn't fixed.

Has anyone fond a way of modifying the attributes of the file in SonicStage to make it recognise these fierls as mp3's?



Standard Member
good luck mate, I am having the exact same problems. A complete pain in the backside.

The only way I have found of getting around this problem is to burn the mp3 to a CD-R as an audio CD and then burning from .cda files straight to Atrac/MP3 files using Sonicstage.

Hope this helps in the interim but I too would prefer a way not using CD-R's!


Established Member
Don't know if it would work or not but might be worth a try you could use something like NERO and you can make Audio-CD image with MP3's and then use something like Daemon Tools and mount the image you made with NERO as a Audio CD then hopefully Sonic Stage might treat the mounted image as a proper Audio CD.

*Update, Just tried the above with my NW-HD1 and Sonic Stage 2.3 and it worked fine. Using NERO6 I made an Audio CD with MP3's burnt this to image file (nrg) mounted it with NERO Imagedrive (daemon-tools should be able to do the same), When I mounted the nrg file autoplay kicked into action and popped up with the option to record with Sonic stage.

The latest video from AVForums

Amazon Fire TV Cube Gen 3 Review: Coming Soon
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom