• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Some Channels not working

Status
Not open for further replies.

satnav

Standard Member
Hi folks , i`ve got an odd one here , some of the channels on my sky plus box aren`t working , No satellite signal is being received is shown , however if i put on a channel that is ok , then record that channel if i now go to a channel that was previously unavaillable i can receive that channel ok .
I have checked both leads seperatley on another receiver and they are both ok so the problem would seem to be with the box .

Some of the Channels that don`t work are ; Ch 5 , sky 1 , sky news ,eurosport, qvc ,ect.

Just wondering if anyone has ever heard of this before or come across it .
Cheers
Chris
 

smarty

Established Member
I'm getting similar problems - intermittent "No satellite signal is currently being received". It also says "For your information 25".
Any ideas? The box isn't very old and I've gone through everything with Sky to reset it and it still does it. Keeps failing recordings and saying "Part Recorded. No signal".
Box is an Amstrad Sky Plus box.
 

theorbhunter

Novice Member
hi i think ive got the solution to all this and its on youtube in the youtube searchbar at the top write in SKYTV NO SATELITTE SIGNAL IS BEING REACEAVED HELP FIX REPAIR the guy on this video tells you what to do and it really works try it your troubles may well be over what ever you do dont phone sky there a total rip off
 

logiciel

Moderator
If you're a Sky subscriber do get in touch with them and ask for the new machine that you could have had ages ago.
 

theorbhunter

Novice Member
I'm getting similar problems - intermittent "No satellite signal is currently being received". It also says "For your information 25".
Any ideas? The box isn't very old and I've gone through everything with Sky to reset it and it still does it. Keeps failing recordings and saying "Part Recorded. No signal".
Box is an Amstrad Sky Plus box.
ive had the very same go to youtube type sky tv no satelitte signal reaceved help fix repair in search bar try it it worked for me
 

theorbhunter

Novice Member
Hi folks , i`ve got an odd one here , some of the channels on my sky plus box aren`t working , No satellite signal is being received is shown , however if i put on a channel that is ok , then record that channel if i now go to a channel that was previously unavaillable i can receive that channel ok .
I have checked both leads seperatley on another receiver and they are both ok so the problem would seem to be with the box .

Some of the Channels that don`t work are ; Ch 5 , sky 1 , sky news ,eurosport, qvc ,ect.

Just wondering if anyone has ever heard of this before or come across it .
Cheers
Chris
check out my quote
 

kevkbuk

Distinguished Member
Wow a 5 year old thread bump... to a video that says turn it off and on again... :D enjoy the extra view.
 
Status
Not open for further replies.

The latest video from AVForums

SVS Prime Wireless Pro Powered Speakers - Review Coming Soon
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom