SOLVED: Anyone got a Yamaha amp and running Kodi 18.8 who could test DTS for me please ?

dazzer28

Standard Member
Hi, I think this has happened since I installed Kodi 18.8. I cant really go backwards to test as its on a dual boot pi where I ran a librelec update too and dont want to break it as has all my retropie set up too !

Any how....

I am pretty sure before before I upgraded to 18.8 when I allowed passthough my amp would display DTS if it received a DTS soundtrack. I have some THX demo tracks so some tracks are DTS some DD and you could see it change on the AMPS display.

But now when I play a demo or a dts movie the amp display does not change at all it does not display DTS, Just sits there showing the name of HDMI 2 being called PI !

When I press the info button on amp remote control, I can see on signal info page it is receiving a DTS 3/2/0.1 signal.
Also within Kodi and the particular movie I can see audio stream is displayed as DTS 5.1 (Side) 6 channels default.
So amp is deffo getting a DTS signal, so not sure why amp is not displaying DTS in the LCD.

When I disable passthrough the amp signal info displays PCM 2.0 .

While the passthough is set to DTS I can use the movie button and select Action, Sci fi etc on amp and you can see the 6 channels etc. But I assume the amp is then manipulating the signal not using the DTS track in it's form it is being passed.

Wondered if anyone had a similar set up and could test a DTS track for me, see if your amp displays DTS when the audio kicks in.

I have been into Audio settings in KODI and have
Enable Pass though enabled
Pass through device is HDMI
Dolby digital ac3 capable receiver is enabled.
Transcoding is disabled
e-ac3 is disabled
DTS capable receiver is enabled.

They are the only options to play with.



For now if I press the DIRECT or the Straight Button will that actually be using the DTS signal, rather than it being manipulated by ACTION . SCI fi etc ?
I have a Yamaha RX-V573 and a RPI3b with KEF eggs

Or shall I just stick it on standard using the movie button/
This is what I am running

LibreELEC-RPi2.arm-9.2.4.img.gz ona pi 3b I think.

Any help would be appreciated.
 
Last edited:

dante01

Distinguished Member
Press the INFO button on the AV receiver's remote to cycle through the display mode options. This will change the type of information being divulged to you by the receiver's display.

You've more than likely accidently pressed the INFO button and changed information what the display divilges?


You can also verify the incoming format by going into the receivers ONSCREEN menu and down to the INFORMATION section. Select the AUDIO option from within the INFORMATION options and the receiver will show what format is coming into the receiver via its onscreen display.
 

dazzer28

Standard Member
Thank you so much, I feel stupid now as that has done the trick !

Wish I posted this a lot earlier before wasting my evening could of watched a 3 hour movie by now.
Yes I could see DTS was being outputted via the "option" button and selecting "signal info" but not see DTS on my display.

I have done exactly as you said with the INFO button instead and scrolled through and watched decoder off turn to DTS when I enabled pass through again. So all working in lovely DTS.

Thanks so much for your help !

Daz
 

The latest video from AVForums

LG G1 OLED EVO Review (OLED65G1)
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom