Sky Wireless Connector dead?

Discussion in 'Sky Digital TV Forum' started by tintin_57, Aug 19, 2013.

  1. tintin_57

    tintin_57
    Active Member

    Joined:
    Oct 29, 2005
    Messages:
    120
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Ratings:
    +3
    Hi, my sky wireless connector has worked fine for just under a year now until yesterday. I have changed my wireless router so I went into Services-Settings-Network to pick up the new router and enter the security key.
    The list of available networks appeared briefly the disappeared. Now the wireless light is off on the front of the connector and in the menu it seems to be searching for a local wired network connection rather than wireless.
    I went through all the setup steps again several times and even changed the Ethernet cable between the HD box and the connector and still no joy. Have also tried the reset on the back of the connector.
    Has anyone else had similar problems? I'm not able to connect the HD box directly to the router and I'm already missing my on demand service.
    Is the connector faulty? Would sky replace it?

    Thanks
     
  2. aurichie

    aurichie
    Active Member

    Joined:
    Apr 7, 2011
    Messages:
    127
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +15
    I'm guessing your new wireless router is using a wifi channel or standard that the Sky wireless connector cannot see. In my experience Sky routers are the best in the business so you should stick to those.
     
  3. Smurkenstein

    Smurkenstein
    Active Member

    Joined:
    Sep 23, 2006
    Messages:
    525
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Ratings:
    +28
    I don't actually have one of these wireless connectors, although I am expecting sky to deliver one soon (I have been waiting nearly 2 months :facepalm:).

    But I could suggest trying to set up an ad hoc network (perhaps using a laptop?) to see if the wireless connector (I am guessing it is actually a wireless bridge) can see any network at all (reading your post, it looks like they all disappeared?).

    Failing that, you should still be able to plug in your old sky router (should be no need to connect to the internet) and see if the wireless connector can detect and recognise it.

    If the connector consistently can't see any network the issue lies with the connector.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice