Sky+ switching with Amp

JoeA3

Active Member
Hi folks,
I have a new Pioneer VSX-1018 AVR, and there doesn't seem to be much info or threads about it on here, but my question is probably more of a general one for pairing Sky+ boxes to AVRs.

I have my Sky+ (SD, not HD) box hooked up to the Amp via optical for the audio, and I'm still using the RGB SCART to the TV for the picture.

When I select "TV" on the Amp, the Sky+ sound comes through the surround speakers, as expected. However, the Amp also forces my TV to switch over to HDMI1, which I do not want it to do! So I end up having to manually select AV1 on my TV remote to go back to the correct Sky input channel.

It's more of an annoyance than a problem, but I'm sure one that there is probably a solution to?!

cheers
Joe.
 

dwhite

Well-known Member
Can you change the assignment of your HDMI inputs, so their isn't one assigned to 'TV'?
 

JoeA3

Active Member
Thanks for the reply.
That doesn't appear to be possible, at least it doesn't seem obvious how to do it!
There is an "Input Setup" menu which allows me to modify settings for the other inputs, e.g. set DVD to use Coax-1, or Optical-1, etc.
However, the HDMI section doesn't allow me change anything!

I think the issue is that the AVR is "paired" up with the TV via hdmi, so that when I switch on the Amp, the TV speakers mute and the changing the TV volume changes it on the Amp instead, and playing a blue-ray forces the TV to auto-switch to the HDMI input on the TV...
This all works very well, but the problem with Sky is that I'm not using the Amp for the "video", only for audio, and this seems to cause the Amp some confusion.

I can disable this HDMI TV <--> Amp pairing and this solves my problem, but it also disables the other useful pairing features I described above.
 

JoeA3

Active Member
any other suggestions anybody ?
 

dwhite

Well-known Member
Get a programmable remote (like the Harmony range) and create a macro that selects the correct input on the tv when you select TV.
 

Jamie

Distinguished Member
I presume that the TV input on the amp probably has a HDMI input associated with it. Perhaps using an optical input without a HDMI assigned will prevent this happening (Wild guess)
 

JoeA3

Active Member
Thanks lads, I tried all that, I checked the input settings for "TV" on the Amp, and apart from allowing me to assign which coax / optical / component connection I wished to use, there was nothing else. No setting for disabling HDMI that I could see.

As I said, if I disable the smart-pairing that seems to work rather well between the TV and the Amp, it solves it... but I don't want to disable that! The Amp even switches off if I switch off the TV, which is handy.

A proper one-for-all remote might be the way to go, cos right now it's ridiculous, I have 4 separate remotes! Are those programmable ones pricey?
 
Last edited:

dwhite

Well-known Member
Jim suggestion was actually to try assigning the optical to an input which won't usually have a HDMI associated with it - CD perhaps. So when you want to listen to Sky you select CD rather than TV, hopefully as no HDMI is assigned, it will work as you want, other than the label being 'wrong'.
 

JoeA3

Active Member
Jim suggestion was actually to try assigning the optical to an input which won't usually have a HDMI associated with it - CD perhaps. So when you want to listen to Sky you select CD rather than TV, hopefully as no HDMI is assigned, it will work as you want, other than the label being 'wrong'.
Aha, I see what you mean now :thumbsup:
There are several optical inputs - at least 3 anyhow, and I have my sky box hooked up to the one labeled "TV-SAT". I might try one of the other optical inputs then, see how that goes!
 

The latest video from AVForums

Podcast: Marantz SR7015 & NAD T 778 AVR + Mission LX2 MKII Speaker Reviews, AV & Film News and More
Top Bottom