Sky Q V2 2tb issues after recent software update

Superm

Novice Member
Hi

I had V1 2tb box which was working perfectly fine. However, when the new recent update (120...) came along the user interface/menu began to stutter/judder/lag. Also if I was watching an episode of a series and hit the back button to stop, it would take me to a completely different episode. I called Sky and an engineer came and replaced it with a V2 2tb box which again, worked fine until it updated to the latest software (120...). I now have the same problem with menu/UI which stutters/judders/lags etc. I had no issues whatsoever on either V1 or V2 prior to the update (which I think is awful) so clearly it's the update that's caused the problems. Was just wondering if other people have had the same issue and more importantly would love to hear from anybody who has a V3 2tb box to see if they are experiencing the same issues as I'm hoping to swap the box for a V3. Would appreciate any replies!
 

dts

Distinguished Member
Try a hard reset.. and if that doesn't work contact sky again and ask for a replacement v3 box.I had issue's with both the v1 and v2 boxes(for different reasons) and had a brand new v3 box sent out,and it's been perfect with no known issues.
 

Superm

Novice Member
Try a hard reset.. and if that doesn't work contact sky again and ask for a replacement v3 box.I had issue's with both the v1 and v2 boxes(for different reasons) and had a brand new v3 box sent out,and it's been perfect with no known issues.

Thank you for replying. I'll give that a go. So did you experience different problems to me on your v1 and v2 boxes? And did DPD deliver your v3 box or an engineer?
 

dts

Distinguished Member
Thank you for replying. I'll give that a go. So did you experience different problems to me on your v1 and v2 boxes? And did DPD deliver your v3 box or an engineer?
Yes the v1 box was a refurbished box,it ran far too hot and had loads of audio drop outs and the uhd picture caused flicker so sky came out and put a new v2 box in.It was fine for about six weeks then I had to keep doing hard resets and the fan was very loud when you turned the box on...so phoned sky to explain the problems(I wanted to actually get rid of the service as it was getting me down...so they arranged a replacement box sent a new box via dpd...i was told I was getting a like for like box....but when did arrived I was given a brand new v3 box...had no problems since.
 

Fergal82

Distinguished Member
The v3 box also comes with issues as seen in one of the other sky q threads.
Audiodrop outs and stuttering menus are some of the recent issues that spring to mind.

Agree with the above though, would be worth trying a v3 if you can get your hands on one.

Sorry forgot to link thread

 

Superm

Novice Member
Yes the v1 box was a refurbished box,it ran far too hot and had loads of audio drop outs and the uhd picture caused flicker so sky came out and put a new v2 box in.It was fine for about six weeks then I had to keep doing hard resets and the fan was very loud when you turned the box on...so phoned sky to explain the problems(I wanted to actually get rid of the service as it was getting me down...so they arranged a replacement box sent a new box via dpd...i was told I was getting a like for like box....but when did arrived I was given a brand new v3 box...had no problems since.

Thanks for the reply and info. I've spoken to another person who also said their v3 box came via DPD so it's very possible all boxes delivered by DPD are v3 ones and the ones supplied by engineers could be anything... I'm tempted to go down the DPD route but I've also heard some people are having problems with their v3 box too. Is yours a 2tb box? I can't remember if you said that....
 

dts

Distinguished Member
Yes its a 2tb v3 box,it was brand new and not a refurbished one..
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom