Sky Q problem with BT HUB

Rno7552

Active Member
Hi all
Hope this forum is able to help me after getting nowhere after 2 hours on the phone last night to Sky.

My beloved wife decided that we needed to switch around our dining and living rooms which meant relocating our tv and sky box.

Have Sky Q 2tb box and BT smarthub 2 with Ethernet connection that has run glitch free since installation over a year ago.

Connected everything up in the new room but can’t get the sky box to connect to hub with either cable or wifi. When in sky setup it was saying connected to router but no internet and inexplicably mentioned a sky ssid not my BT network name. I have a number of other devices, phones,Mac,tablets,cctv,Alexa,Hue all connected by either Ethernet or wifi and all working ok.

Spent 2 hours last night with a really helpful sky agent who persevered and tried everything including factory reset of sky, reboot of router. Finally managed to get the sky setup to display my BT network name and although sky is connected to it it’s not connected to internet. BT troubleshoot revealed no issues with my BB. The only step I’ve not taken is a router reset as with around 30 devices I can’t face going round reconnecting them all and if all my devices are connecting I can’t see that working anyway.

Sky are sending an engineer next week and I’m hoping a replacement box will fix the issue but just wondered if anyone out there has experienced anything like this before.

Cheers
 

Venomx999

Active Member
HH2 is quite old. see if BT can give you a HomeHub6
 

Rno7552

Active Member
Hi, thanks for reply.

The hub is the smarthub 2 which BT assure me is the latest available.
 

Venomx999

Active Member
Hi, thanks for reply.

The hub is the smarthub 2 which BT assure me is the latest available.

I do apologise ! They do smart hubs and home hubs. The latest HomeHub is 6 and the latest Smart Hub is 2.
 

Venomx999

Active Member
It may have something to do with DHCP in the router.
 

cunnas

Well-known Member
I can't help but I have had similar issues with Sky Q and Virgin. It took the engineer ages to get Sky Q to connect to Wifi and then more problems getting the mini Sky Q box in the bedroom to connect. Sky recently lost wifi again and it took me hours to sort - in the end it was just sheer luck. I could only suggest doing what I did and that was to turn everything off (router and Sky). Power on the router and make sure thats working fine, power on Sky Q main box and connect to wifi/ethernet, then if that works power on the mini box. Can't guarantee it will work as it took about 4 attempts for all 3 devices to be working together for me.
 

Abayomi

Active Member
Did you go into the "secret" sky q engineer menu. Your initial post indicates it is trying to connect via the sky wireless network which is separate to the "normal" wireless so as it is not connecting this would indicate that sky wireless is not on in the main sky q box
The factory reset of the Sky Q box probably turned off the ethernet connection as the standard connection method is wireless
Worth Having a check
Sky Q Engineers menus access as follows
Press in quick succession with no breaks between steps.
  1. Press the ‘Home’ button on your remote control.
  2. Scroll down to ‘Settings’ and DO NOT press select.
  3. Press ‘001’.
  4. Press ‘Select’
 

Rno7552

Active Member
Did you go into the "secret" sky q engineer menu. Your initial post indicates it is trying to connect via the sky wireless network which is separate to the "normal" wireless so as it is not connecting this would indicate that sky wireless is not on in the main sky q box
The factory reset of the Sky Q box probably turned off the ethernet connection as the standard connection method is wireless
Worth Having a check
Sky Q Engineers menus access as follows
Press in quick succession with no breaks between steps.
  1. Press the ‘Home’ button on your remote control.
  2. Scroll down to ‘Settings’ and DO NOT press select.
  3. Press ‘001’.
  4. Press ‘Select’
Hi and thanks for the reply. During my call with sky I was in and out of the secret menu several times and the reset did remove the link to the sky network but on the sky network setup page it’s showing my correct by network name and a tick for connected to router but a x against internet connection.
Just come off the phone to but fibre, they say all their checks are looking fine and maybe try a factory reset of the router.
 

Rno7552

Active Member
I can't help but I have had similar issues with Sky Q and Virgin. It took the engineer ages to get Sky Q to connect to Wifi and then more problems getting the mini Sky Q box in the bedroom to connect. Sky recently lost wifi again and it took me hours to sort - in the end it was just sheer luck. I could only suggest doing what I did and that was to turn everything off (router and Sky). Power on the router and make sure thats working fine, power on Sky Q main box and connect to wifi/ethernet, then if that works power on the mini box. Can't guarantee it will work as it took about 4 attempts for all 3 devices to be working together for me.

Hi and thanks for responding.

I guess some of my reply to you will overlap my reply to the post from Abayomi.

It sounds like my issue is similar to the one you experienced so I’ll be giving that a go later and will post an update.

Cheers
 

MikeHoy

Active Member
in your Sky Q go to settings, move to the right and down to network connection
move to the right network setup. go to advanced.
are you using auto or manual for the settings. I would suggest manual and set every thing your self. hopefully you know the router address and DNS server, I use a separate DNS and DHCP server and don't rely on the router, but will not be an issue. Just wondering if there is an issue with DHCP.
 

chazman88

Active Member
in your Sky Q go to settings, move to the right and down to network connection
move to the right network setup. go to advanced.
are you using auto or manual for the settings. I would suggest manual and set every thing your self. hopefully you know the router address and DNS server, I use a separate DNS and DHCP server and don't rely on the router, but will not be an issue. Just wondering if there is an issue with DHCP.

I would (personally) be very very careful setting everything to manual unless you know EXACTLY what settings you require for IP Address, Subnet Mask, Gateway and the DNS servers.

If all of your other devices connect fine then I would assume that the DHCP is working properly and this is not the issue.

How was the Sky Q box connected before you moved the room round?

I can’t remember exactly where the setting is in the Sky Q menu but have you done the “network reset”? This would be my first thing, then follow the wireless setup guide (unless you’ve got it connected with a wire directly to your router then you can literally ignor everything that mentions WiFi)
 

Rno7552

Active Member
Another update.
Before taking the plunge to factory reset my hub I disconnected all the wired connections on my network and then went through the wifi setup again on the sky box - it connected!!!!!
Then got my sky mini box working as well.
Just as I was about to start setting up all my wife’s recordings that were deleted the sky box disconnected
Over the last few minutes it has disconnected a few times then automatically reconnected.
It has now stayed connected for about 5 minutes.
Any thoughts?
 

agmpav

Novice Member
I had months of connectivity problems between my BT Hub and Sky Q Mini. I changed my wifi channel via the 'secret' menu, clear as a bell now.
Slightly different to your problem but might be worth a try.
 

Rno7552

Active Member
Ps even though all looks ok on setup screen and my wife is happily downloading Jeremy Kyle (no comment) when I go into the Apps menu there is a message saying “to enjoy this service we must have an active internet connection “ but catch up, on demand etc are all ok

Ignore - just refreshed apps through secret menu and they’re back. Moreover another 5 mins have passed and I’m still connected.
Now, do I risk reconnecting the Ethernet?
 

Rno7552

Active Member
in your Sky Q go to settings, move to the right and down to network connection
move to the right network setup. go to advanced.
are you using auto or manual for the settings. I would suggest manual and set every thing your self. hopefully you know the router address and DNS server, I use a separate DNS and DHCP server and don't rely on the router, but will not be an issue. Just wondering if there is an issue with DHCP.

Hi, grateful to you for your reply.
If I follow the above when I have a connection is that the same as assigning a static IP address?
If the connection stays ok what do you think might happen if I revert to a wired connection?
 

MikeHoy

Active Member
You are setting a static IP address doing it that way, it is not a reserved address.
If the Q is powered of at the mains for a period and you connect a new device it is possible that the new device may pick up that IP, but fairly slim. You could set the wired to static as well, just use the next address up. You may need to check what addresses are being dished out by the router so as not to get an IP conflict. My Q is wireless to a BT Hub 5 and works perfectly fine, the Hub is in my loft and the wireless signal to the main room is very strong. As long as you know:
Your router IP, the subnet mask and the DNS settings it is not hard to use a static address.
 

mbmapit

Well-known Member
Have you turned off the setting whereby when new items connect to the network they get a BT greeting page (I can't remember what it's called but it's on by default)?
 

tom 2000

Distinguished Member
Smart Set Up?
 

Rno7552

Active Member
Another update.
Had a stable wifi connection for some time after turning off smart setup, setting sky box ip manually (all boxes were refilled), set hub settings to always use this ip for sky - so far so good.
Only fly in the ointment is that when I connect by Ethernet the IP address changes to one that looks nothing like the range on my hub and connection fails. When I revert to wifi all is ok.
If I promise to make this my last question can anyone help me to set this up wired as that is my preference
 

tom 2000

Distinguished Member
It all beats me. I have wifi disabled on all my boxes. One mini was deciding not to wake up this evening so I turned off all boxes, restarted router and sky boxes one by one and patiently waited and it was all automatic.
When I say not wake up that is incorrect, it refused to join the network and would not acquire an ip address. It wanted me to press buttons on nearby devices which is a nonsense on wired network.
 

MikeHoy

Active Member

It is the same as for wireless to set the static IP
 

Rno7552

Active Member
Mike, thanks again for your perseverance
I have previously followed the steps in that video but when I get to the stage about 2 mins 30 in is where I hit a problem.
Instead of connecting to my router with an IP address the sky box picks up an IP address of 10..0.1.21 and a sky ssid which I’m guessing may be the sky mesh for sky q.
My hub settings will not allow me to delete this device so I feel I’m going round in circles.
The only thing I can think of to get rid of this would be a factory reset of the router and then connect back up. At the moment however the wifi connection is stable and the look on my wife’s face when I say “just another tweak” is frightening - at this rate I could end up on the Kyle show myself with a strap line of “ my husband infuriates me!”
 

tom 2000

Distinguished Member
When you get the box to yourself try turning wifi off and reset connection.
 

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...

Latest News

AVForums Podcast: 27th January 2021
  • By Phil Hinton
  • Published
Philips introduces new 9206 and 8506 LED Android TVs for 2021
  • By Andy Bassett
  • Published
Philips unveils 9636 and 9506 MiniLED TVs
  • By Andy Bassett
  • Published
Philips announces 806, 856 and 706 OLED TVs for 2021
  • By Andy Bassett
  • Published
Falcon Acoustics launches Q7 speaker kit
  • By Andy Bassett
  • Published
Top Bottom