SKY Q - have i made a huge mistake?!

Do you wish you never upgraded to SKY Q?


  • Total voters
    85
  • Poll closed .

PMac1

Novice Member
I upgraded from Sky HD to the 1TB box which had constant sound dropouts when using the optical inputs on my amp. Lots of calls with Sky and a couple of visits from Sky engineers didn't resolve it so they recommended a further upgrade to the 2TB box. And its exactly the same! Sky have no further advice to offer so I'm stuck in a deal I can't now get out of. On the positive side there's no sound issues using the AV input so I use this for TV and Spotify Connect works well on the digital input.
 

Teerex

Active Member
I also had issues with connectivity when I had 2tb box and a mini. The mini was closest to the router but connected via ethernet and so was the 2tb box. The mini was also connected to the 2tb box via WiFi but would always lose connection to the 2tb box. It was very annoying and I didn't mind giving up the mini in the end. I had to reboot the mini all the time.
 

nelson1j

Standard Member
I had similar issues to you and ended up doing the following.

Loved sky booster so that it was half way between sky mini and main skq 2tb box.

Also experimented with changing the channel sky q was using to talk to main box and booster helped. Think u need to access service menu for this to work. Was a real pain to get working properly but now setup is ok alt although still get occasional dropouts.
 

evans88

Active Member
I have a large house and consequently had connection difficulties between the main and mini boxes. Contacted Sky and they sorted the issues out by providing boosters. I suggest the OP contacts Sky. In my case they responded very quickly and efficiently.
 

ChuckMountain

Well-known Member
which had constant sound dropouts when using the optical inputs on my amp.
Did you try HDMI and what amp did you have. My older Yamaha AV2067 suffers from this on the Mini box but only if DD is enabled ... My main box with a slightly newer AVR doesn't :(
 

PMac1

Novice Member
Did you try HDMI and what amp did you have. My older Yamaha AV2067 suffers from this on the Mini box but only if DD is enabled ... My main box with a slightly newer AVR doesn't :([/QUOTE said:
Its an Audiolab 6000A connected to a pair of Q Acoustics floor-standers. The amp doesn't have a HDMI port so unfortunately that isn't an option. As I mentioned there's no sound drop outs when using the AV input but the sound is so much better via the DAC. It also means I need to switch sources on the amp every time I change from TV to music (and vice versa) which is a pain..
 

PMac1

Novice Member
HDMI from Sky Q to the TV then red/white RCA cables to the amp - standard stereo rather than surround sound.
The amp was only released July last year so should be compatible.
 

Kelmscott

Active Member
I wonder if your two mesh networks don’t play nice together?

Have you tried, as a test, switching off the Linksys Velop mesh network and then seeing if the Sky Q and its satellite device(s) now work OK?

No idea what you do if that pinpoints the issue, though....

When checking my WiFi, I carry around my Android phone with the WiFi Analyzer Classic app, which has all sorts of useful displays and indicators.

Other similar apps are also available on the Google Play Store, some with higher ratings, but I can’t speak for them.

And nothing like this is available on iOS, as Apple don’t allow some of the discovery methods such apps need, so it must be Android.
 

PMac1

Novice Member
[QUOTE="Ok did you output it as stereo or DD? I think Sky Q has something weird going on that some amps including one of mine don't like.[/QUOTE]
Drop outs are happening irrespective of whether the output is set to DD or normal. I did wonder if hard wiring via the Ethernet would help but the HD picture itself is fine and never freezes.
BTW thanks for your help with this :)
 

JayCee

Distinguished Member
And nothing like this is available on iOS, as Apple don’t allow some of the discovery methods such apps need, so it must be Android.
I use “Fing Network Scanner” on my iPhone/iPad.
Available from the Apple app store.
 

Kelmscott

Active Member
I use “Fing Network Scanner” on my iPhone/iPad.
Available from the Apple app store.
Yes, I have Fing on this iPad.

Do you have a Fingbox? I keep meaning to buy one, but missing the special offers. Perhaps it will do more with a linked Fingbox...

But the Fing app on its own, is working a level down from WiFi Analyzer, telling me what devices are on my router, while WFA shows me what’s competing with my router for the airwaves. So these are complementary Apps, and having both is useful.

But I can’t walk around my house with Fing, and have it tick-tick-tick fast where WiFi is strong, and slowly where it’s weak, like WFA can. Sure, Fing has the three level bars, or at least the iPad does. But these don’t tick, and they are just indicators, not the dBm meter of WFA.

And I can’t see all the competing WiFi signals in my home and outside on a dynamic graph on Fing,

Or see which router channels are crowded, and which are relatively free, so I can switch to the best one.

If you have an Android device, download and try the (free) WiFi Analyzer Classic.

I think you will be blown away by what you can do with it.

And while you can get Fing on Android, Apple won’t let you have WFA, or anything like it, on iOS.
 

Kelmscott

Active Member
Try WiFiman by Ubiquiti.
Thanks for the suggestion. I downloaded this on my iPad, and it will certainly give Fing a run for its money.

But again, it doesn’t go ‘above’ your connected WiFi to tell you about other routers in range, nor give you that all-important signal meter for finding your hotspots and hotspots, like WFA does.
 

strike4A

Standard Member

MikeHoy

Active Member
Thanks for the suggestion. I downloaded this on my iPad, and it will certainly give Fing a run for its money.

But again, it doesn’t go ‘above’ your connected WiFi to tell you about other routers in range, nor give you that all-important signal meter for finding your hotspots and hotspots, like WFA does.
If you tap the WiFi you want to look at in the list it gives you the signal meter with audio beep.
Is that what you are looking for.
 

Kelmscott

Active Member
If you tap the WiFi you want to look at in the list it gives you the signal meter with audio beep.
Is that what you are looking for.
Yes, but only on Android - like Fing, it’s not there on the iOS version. OTOH, Fing doesn’t do any of that on Android even though it could, so it is outclassed on Android by both WiFi Analyzer and WiFiman.

But it’s not intuitive to find that signal meter on WiFiman, and even the blog introducing it just shows that it’s there, without explaining how you access it, and I can’t find any Help for it anywhere.

Not sure what it does that WiFi Analyzer doesn't, beyond the speed test I have with Ookla anyway, and doesn’t have the channel rating, or the Help, so for me WiFi Analyzer still has the edge.

But both are free, so we can have both - horses for courses :)
 

FaxFan2002

Well-known Member
I had a mesh network issue when first getting Sky Q & mini boxes. Specifically this was with a Sonos mesh network. I have to change Sky Q to specific channel that Sonos wasn't occupying as Sonos couldn't be changed.

Use a wifi analyzer to check the channels each system uses and separate them.
 

MWRTXT35

Active Member
After pressure from my son, we decided to get Sky Q last week. Ours is a quite large house, spread out over various levels with a dedicated ATMOS cinema room on top of a double garage at one side of the main house. A lounge where I wanted the Q Mini Box to be installed is on a different level on the opposite side of the house. Both rooms are some distance from the router which is in an office right at the top of the main house. Unsurprisingly I anticipated we would have potential connection issues and so attempted to alleviate problems by establishing a 'seamless' wi-fi signal throughout the house using TP Link powerline adapters. I've been using these successfully for a while to get wi-fi in the main rooms, but some were older than others and wouldn't mirror the router's passwords etc., so I bought new ones ....and it worked! The Sky engineer was perhaps as surprised as me when it all seemed to gel. So I was happy......until we watched TV in the cinema room that night. My AV kit includes an Epson 9300W projector and the picture was bloody dreadful. I had read on this forum that others had managed to get the 2160p 8 bit output settings within the Q box to work, but despite several attempts, these 2160p settings would not initiate - all I could achieve was 1080i and the picture was much worse than my old Sky+ had been. I reluctantly decided to telephone Sky to take the Q away and reconnect my old kit....but just before doing so, I had a brainwave. An OPPO 103 and Sky are connected via HDMI leads into a Marantz 7704 processor and a third HDMI lead takes the picture signal out of the processor 'Monitor 1 ARC' into the Epson's WiHD transmitter to wirelessly send the picture to the projector. This third lead looked a bit flimsy compared with the others, so I changed it.....and thank goodness I did! The 2160p 8 bit setting immediately initiated and the picture sprang into life on the screen with UHD viewing options now available in the menu. I'm delighted with the picture quality and the Atmos sound on live football is rather good. So having an Honours Degree in Stating The Obvious......I almost fell foul of the most basic of mistakes with this - sometimes seemingly insurmountable problems can be sorted with the simplest of remedies.....So is Sky Q worth having...? Well despite the mini box dropping out once or twice, usually when browsing on a tablet, I'm happy with it and glad I made the switch.
 

FaxFan2002

Well-known Member
I hope this has been said before but the Sky Q devices create a "private" network between themselves on the 5Ghz network - so you MUST make sure this channel doesn't clash with your existing 5Ghz network. If it does it you'll get drop outs especially when using devices that share the channels.

inSSider appears to be a chargeable tool now, but Acrylic is free and you can view the channels. The Sky ones can be changed.

Connecting the Sky Q boxes to the normal network is purely for the internet based content, the actual picture for channels comes via the "private" network. You can get a booster for this if you have a large house.
 

steve33shoreham

Active Member
I’m still not convinced by these Sky Q mini boxes and am have terrible connection issues and am going out of my mind trying to sort it (and by the ear bending from my other half and toddler when Paw Patrol drops or freezes!)

The Sky engineer and booster made an improvement to my connection but still disconnected far too often, so I went with the powerline option which seemed to be generally stable.

However the connection is still dropping out and am having weird results. I’m baffled trying to set this up because of what is and isn’t working.

Current Setup part 1:

I have the Main Q in Lounge and 2 mini’s the kitchen and bedroom which are connected to gigabyte TP Link powerlines.

Main Q – hardwired to my BT Hub 6 router which is hard wired to the main TP Link gigabyte powerline. Wifi setting currently set to 5ghz only (reason for this is because of the issue 1 below). No issues and a very happy with the upgrade over the Sky HD box.

Kitchen – hard wired to a powerline and so the box didn’t override and connect by either 2.4 of 5ghz wifi I turned these off in the installer settings. Generally works ok but still with occasional drop outs and freezes which I put down to maybe the buildings wiring or the powerlines.

Issue 1:

Now in theory as the kitchen mini wifi is switched off and supposedly connected by the powerline, I should be able to switch off the 5ghz on the main Q.

However when I do this I lose the kitchen connection. So leads me to think that either the kitchen mini is not using the powerline for the Sky Q connection even though the wifi has been disabled.

Otherwise why would disabling the 5ghz on the main box disconnect the mini box which the wifi is disabled on?

Current Setup part 2:

Bedroom - Leaving that issue aside the Bedroom mini as with kitchen is hard wired to a powerline. However the 5gsz wifi is still enabled otherwise I get my next issue:

Issue 2:

When I disconnect the wifi on this mini it loses the connection to the main Q (the kitchen one doesn’t) BUT it also knocks out the connection on the kitchen mini?!?

Why would disabling the wifi on one mini knock out another? Is it something to do with its in built mesh system?

I did read online that when using powerlines you should try and connect a mini from scratch which I have tried resetting and connecting by ethernet, but the kitchen one won’t setup and reconnect unless the 5ghz is activated on the main Q box.

Summary:

So in short all three are connected by gigabyte powerlines but the only way I have been able to get the minis to work is by:

  • Sky Q main: Wifi set on to 5ghz otherwise both minis both disconnect regardless of their individual wifi settings.
  • Mini (Kitchen): Wifi set to off with some dropouts but if Main Q or Bed Mini wifi disabled this will disconnect.
  • Mini (Bed): Wifi set on to 5ghz otherwise the minis both disconnect.

Please help me if you can oh mighty forum before my family murder me.
 

Kelmscott

Active Member
I would hypothesise that the bedroom mini is feeding the kitchen mini over the 5Ghz wifi, which is why it stops when you turn off the 5Ghz on either the Q box or the bedroom mini.

I suggest you unplug the bedroom mini, unplug the bedroom PLA, don’t try to use the Booster (maybe you aren’t, but this isn’t clear), turn off any WiFi on and then unplug the kitchen mini, unplug the kitchen PLA, unplug the Sky Q PLA, and finally turn off the WiFi completely on the Sky Q box (since as far as I can tell, you don’t intend for it to be used at all).

Now we are at ground zero.

Next, reboot your router, and when it settles, reboot the Sky Q box, and when that settles, reconnect, and reboot if you can, the PLA going from the Sky Q to the mains, and when that settles, the same with the kitchen PLA, which you may have to re-pair with the one at the Sky Q end. And then reconnect and reboot the kitchen mini.

So this is now all-Ethernet, or should be, all refreshed, and it ought to work.

Does it?

If not, check the PLAs are working as they should; plug in a laptop with its WiFi disconnected in the place of the mini, and see if you can reach the internet.

If not, you have one or more faulty PLAs, or maybe split house wiring, or some such ill. PLAs don’t like multiway plugs, so make sure both are directly into a wall socket.
Take the kitchen PLA and plug it in as close as you can get to the Sky Q one, preferably in the same double socket. Repeat the laptop test. If this now works, you may have a split mains problem, which you will need a qualified electrician to look at. If it still doesn’t work, suspect the PLAs, maybe try the bedroom one to see if that is OK in place of the kitchen one.

If it still doesn’t work, I’m out of ideas, and you will need to talk to Sky about this; maybe you have faulty Sky kit, or they know something I don’t (which is highly likely).

But if you got the kitchen mini working, repeat as above for the kitchen PLA step onwards with the bedroom PLA, which you may have to re-pair with the one at the Sky Q end. And then reconnect and reboot the bedroom mini.

If it now works without WiFi, great. If not, do the laptop steps for this connection.

Good luck!
 

ChuckMountain

Well-known Member
Why would disabling the wifi on one mini knock out another? Is it something to do with its in built mesh system?
Yes it a mesh if that one happens to the one between two other points, disabling it would knock it off the "grid"
TP Link gigabyte powerline
No powerlines are capable of doing anything like a gigabit of throughput. For starters the advertised speed is duplex so throughput would be half the indicated speed. Typically you would be lucky if you get 1/10 of the advertised speed.

I would make sure you start again from scratch as you have read as it maybe something that has switched itself back on ...
 

tdodd

Novice Member
I have only one mini, hardwired via a TP-Link powerline adapter. WiFi is disabled on both the Sky Q 2TB and the mini. Operation is faultless.

I did make some network config changes a couple of weeks ago and did set up the Sky system from scratch. It was important to have the hard wires operational before setting things up. I did try without and you cannot reverse out of a WiFi set up, you have to start from scratch. For me it works reliably, day after day.

FWIW I have a Sky Q hub, acting as a dumb FTTC modern and I have an Asus gaming router (GT-AC5300) in the DMZ acting as DHCP server and providing all router functions. I doubt this has any bearing on my success, but worth a mention just in case.

I really don't know what to suggest, other than starting over. Maybe use a TP-Link utility/app/browser interface to check link speeds and stability. Also, do not plug powerline adapters into extension leads if possible, and absolutely not into extensions with surge protection.

Good luck.
 

steve33shoreham

Active Member
Yes it a mesh if that one happens to the one between two other points, disabling it would knock it off the "grid"


No powerlines are capable of doing anything like a gigabit of throughput. For starters the advertised speed is duplex so throughput would be half the indicated speed. Typically you would be lucky if you get 1/10 of the advertised speed.

I would make sure you start again from scratch as you have read as it maybe something that has switched itself back on ...
Thansk Kelmscott and ChuckMountain i will give that a go.

Chuckmountain, regarding the Mesh aspect, if the Kitchen Mini wifi is turned off, why would disabling wifi on the Bed Mini knock out the Kitchen one?

The only reasons i can think is that Wifi is not actually disabled on the Kitchen Mini, or the Kitchen is connected to the Bed over powerline and the Bed to the Main Q by Wifi.

The last option of this seems more likely the more i think about it.

Therefore might take either the Bed or Kitchen Mini and powerlines out of the equation completely and see if i can concentrate and connect one Mini and Powerline first before adding the other.
 

THX1138UK

Active Member
I d
I’m still not convinced by these Sky Q mini boxes and am have terrible connection issues and am going out of my mind trying to sort it (and by the ear bending from my other half and toddler when Paw Patrol drops or freezes!)

The Sky engineer and booster made an improvement to my connection but still disconnected far too often, so I went with the powerline option which seemed to be generally stable.

However the connection is still dropping out and am having weird results. I’m baffled trying to set this up because of what is and isn’t working.

Current Setup part 1:

I have the Main Q in Lounge and 2 mini’s the kitchen and bedroom which are connected to gigabyte TP Link powerlines.

Main Q – hardwired to my BT Hub 6 router which is hard wired to the main TP Link gigabyte powerline. Wifi setting currently set to 5ghz only (reason for this is because of the issue 1 below). No issues and a very happy with the upgrade over the Sky HD box.

Kitchen – hard wired to a powerline and so the box didn’t override and connect by either 2.4 of 5ghz wifi I turned these off in the installer settings. Generally works ok but still with occasional drop outs and freezes which I put down to maybe the buildings wiring or the powerlines.

Issue 1:

Now in theory as the kitchen mini wifi is switched off and supposedly connected by the powerline, I should be able to switch off the 5ghz on the main Q.

However when I do this I lose the kitchen connection. So leads me to think that either the kitchen mini is not using the powerline for the Sky Q connection even though the wifi has been disabled.

Otherwise why would disabling the 5ghz on the main box disconnect the mini box which the wifi is disabled on?

Current Setup part 2:

Bedroom - Leaving that issue aside the Bedroom mini as with kitchen is hard wired to a powerline. However the 5gsz wifi is still enabled otherwise I get my next issue:

Issue 2:

When I disconnect the wifi on this mini it loses the connection to the main Q (the kitchen one doesn’t) BUT it also knocks out the connection on the kitchen mini?!?

Why would disabling the wifi on one mini knock out another? Is it something to do with its in built mesh system?

I did read online that when using powerlines you should try and connect a mini from scratch which I have tried resetting and connecting by ethernet, but the kitchen one won’t setup and reconnect unless the 5ghz is activated on the main Q box.

Summary:

So in short all three are connected by gigabyte powerlines but the only way I have been able to get the minis to work is by:

  • Sky Q main: Wifi set on to 5ghz otherwise both minis both disconnect regardless of their individual wifi settings.
  • Mini (Kitchen): Wifi set to off with some dropouts but if Main Q or Bed Mini wifi disabled this will disconnect.
  • Mini (Bed): Wifi set on to 5ghz otherwise the minis both disconnect.

Please help me if you can oh mighty forum before my family murder me.
I don’t have Sky Q, but a couple of points that may help with your Wi-Fi trouble-shooting.

2.4 GHz Wi-Fi supports the 802.11n standard which usually tops out at 150 Mbps (and you only get half that bandwidth). The signal is generally fairly good at passing through internal walls and floors (proving there is no metal foil around insulation). 2.4 GHz can become more congested, because there are only a few channels available. If you live in a built up area, then your neighbours Wi-Fi may well be trying to use the same channels as you, which causes the bandwidth to drop significantly as it has to be shared.

Microwave ovens (when operating) emit interference in the 2.4 GHz range which can cause drop outs.


5 GHz Wi-Fi supports 802.11ac supports much higher speeds, but 5 GHz is *very* poor at passing through walls and ceiling. It is however, far less likely to suffer from interference from other home devices.

There are more channels available in the 5 GHz range, so you’re less likely to suffer congestion.


If a Wi-Fi device has two radios (2.4 GHz & 5 GHz) it will generally lock onto a 5 GHz signal transmitted from the Access Point (even if it is much weaker) - I’ve recently been trouble shooting a fairly complex Wi-Fi LAN and I ended up disabling all the 5 GHz radios on the Acess Points, and this improved performance massively, because the 5 GHz signal was so constrained by walls etc, which didn’t cause any problems for the 2.4 GHz signal.

Sounds like Sky Q uses a mesh network where each node can pick the best hop to its neighbour.

Some Wi-Fi devices allow you to create separate SSIDs (network names) for the 2.4 GHz radio and the 5 GHz radio. This can make it easier to troubleshoot problems.

If you have a modern laptop that supports 2.4GHz and 5 GHz then you can download the inSSIDer utility for Windows and this will show all the Wi-Fi networks, channels, frequencies and potential problems, Ideally, you don’t want any networks sharing channels.

The are many, many reasons why Wi-Fi may prove unreliable when you are trying to stream high-bandwidth content.

Regards,
James.
 

steve33shoreham

Active Member
Thank you all very much for your help and (touching wood
:face_savoring_food:
) all is working well and stable at the moment.

I did find a fault with my powerlines and it was as i thought, the Main Q box was only connecting via wifi and to the Bed Mini. The Kitchen Mini was connected to the Bed over powerline so when the wifi was disabled on the Bed or Main, the Kitchen dropped out too.

I disconnected both minis, reset and repaired the powerline network and tested the netowrk, turned off the wifi on the Main Q and then reinstalled the Minis one by one, they all connected fast and faultlessly!.......

.....so far.

I did get another problem late last night with the Main Q, as i unplugged the HDMI from the TV into my AV Receiver as i wanted a Sky broadcast to my projector via the HDMI 2 out on my Denon (normally sound is via the ARC)

However when i plugged it back into the TV i got a black screen and couldn’t get any picture.

Apparently this is an ongoing issue with the Q and whether it was the resolution change (TV is 4k and PJ is on 1080) or the Receiver i don’t know but turning the Q on and of again got it back working and fro now on I’m touching nothing! Sky Q blank Screen



Again thanks all for your help.
:thumbs_up:
 

Kelmscott

Active Member
Not bad guesses of mine, then, considering I haven’t even got any Sky Q equipment :p - glad you got it sorted.

With HDMI devices, you aren’t supposed to hot-swap them. I don’t think it causes any harm if you do, and usually you can get away with it, but strictly, you should have both devices you are connecting in standby, connect them, and only then fire them up again.

If you do it, differently, you can get what you have just experienced, and the advice is turn both devices off and on again; and as you say, things were OK when you did that.
 

steve33shoreham

Active Member
Writing it down and reading it back on here actually helped to. Thinking about it in my head wasnt making sense and as one powerline link was working (albeit to the Bed Wifi connected Mini) it didn't compute that the main powerline on the Q was the issue as the ink worked elsewhere.

I didn't know about hot-swapping to be fair so i will be careful of that in the future. :smashin:

I should have the Sky directly through the AVR, (although i think that still causes the blank screen issue due to resolution change between TV and PJ) but it makes life easier for my other half the sky having its on source, whereas all the others are vie the AVR.
 

Similar threads

Trending threads

Latest news

Master & Dynamic introduces MW07 Go and MW07 Plus wireless earphones
  • By Andy Bassett
  • Published
New Nvidia Shield devices 25 percent faster and add Dolby Vision
  • By Andy Bassett
  • Published
Netflix gets subscriber boost ahead of rival's challenge
  • By Andy Bassett
  • Published
Samsung Galaxy S10 bug unlocks phone for anyone
  • By Andy Bassett
  • Published
Apple TV app now available on Roku devices
  • By Andy Bassett
  • Published

Latest threads

Top Bottom