Sky Q constantly disconnecting from the Internet

inkinoo

Distinguished Member
Bit of a weird problem. All my Sky Q boxes will constantly disconnect and reconnect from the Internet. It will say “Connected”, then three seconds later say problem with the Internet l, three seconds later back to Internet.

Mini boxes will talk to the main box just fine and I’m on a wired connection.

Any ideas?
 

jonoro

Active Member
I am surprised you haven't received helpful comment yet.
Although I have not had this with Sky I did have one device that would frequently disconnect.
Look on the main Q box under Settings, Setup,, Network, Advanced and note the ip adcresss, then move to Set manually and enter the same ip address, then enter the Mask numbers using the same mask numbers that appear, which will be 255.255.255.0 and the router numbers similarly. The router address should be same as the ip noted at the start except the final entry will be 1 .
 

inkinoo

Distinguished Member
Cheers for the reply. Tried setting manually before, made no difference. Even put it the other side of my Unifi router, made no difference.

I just know calling Sky will be a whole world of pain.
 

jonoro

Active Member
Not only a whole world of pain but an eternal wait untill the pain begins!
An ip clash? Try asining a different ip.

Could it be that the Sky box's wifi module is trying to connect?
I have the wifi turned off in my Q box.
 

jonoro

Active Member
Does sound like a new box needed.
Sky were at one stage doing remote replacrments I seem to recall where they courier you a new one and the courier takes the old one. But maybe a Covid-19 thing.
Good luck.
 

inkinoo

Distinguished Member
Sorted it. It was related to IPv6. Apparently there is a bug on non Sky Broadband connections. Doable that and it works.
 

goatlips

Well-known Member
Currently my sky Q box will not connect to the Internet, I managed to pair it last night but again its not working today and will not pair. Any ideas?
 

jonoro

Active Member
The only pairing with Sky Q is for the remote's blutooth setup. There is no pairing to do with internet connection.
 

goatlips

Well-known Member
The only pairing with Sky Q is for the remote's blutooth setup. There is no pairing to do with internet connection.

Well you have to press a button on the router and sky q box...??
 

jonoro

Active Member
That is nothing to do with pairing.
The link remote to Sky Q box is Bluetooth, that requires pairing.
The link router to Sky Q box is wifi (or can be wired) that is not "paired".
The button on the router you press is to copy the passphrase i.e. SSID password from the router to the Sky Q box.
If the system router-Sky Q box is failing, try rebooting both of them, and enter the router's passphrase into the Sky Q box manually.
 

inkinoo

Distinguished Member
I’ve had to do the same procedure with my wired boxes and no Sky router. What is it doing then?
 

jonoro

Active Member
The button on the router is a WPS button.
The clue is in the name "Wifi Protected Setup".
If you are all cable connected and not using Wifi for Sky then I don't know what you are doing.
 

inkinoo

Distinguished Member
The button on the router is a WPS button.
The clue is in the name "Wifi Protected Setup".
If you are all cable connected and not using Wifi for Sky then I don't know what you are doing.
In trying to troubleshoot my Sky problems, I moved all the boxes to a different network with a different subnet. The only way I could get the Mini boxes to see the Main one was by pressing that button as instructed by the on the screen display.

It didn’t turn on WiFi as I am connected via cables.
 

jonoro

Active Member
Unless you specifically turn off the wifi the boxes can still try and use Wifi.
That may be the source of your troubles.
If you are all wired connections turn off Wifi in al, the Sky Q noxes
 

inkinoo

Distinguished Member
Unless you specifically turn off the wifi the boxes can still try and use Wifi.
That may be the source of your troubles.
If you are all wired connections turn off Wifi in al, the Sky Q noxes
The WiFi is 100% off since day one install.
 

jonoro

Active Member
Then you must be using Wifi for a connection.
Merely plugging in a network cable does not guarantee that you are not using Wifi for that connection.
 

jonoro

Active Member
In which case the Wifi button will do nothing if Wifi has been disabled!

The symptoms you describe can be caused by having both a wired connection and a Wifi connection at the same time. I emphasise the "can"; there may well be other causes.
 

IL Cattivo

Distinguished Member
I have come to the conclusion that the SkyQ boxes are unfit for purpose using WiFi equipment other than that provided by Sky themselves (i.e Sky broadband routers/extenders)

I, like @inkinoo am using UniFi Wireless (mine are PoE NanoHD Access Points)
When I used to have the Main SkyQ box in the lounge (hardwired) and the Mini upstairs in my office talking to the Main via Sky's in-built 5Ghz mesh, I never had any issues. Since swapping them over and thus having to force the MainQ to use its preferred 2Ghz WiFi channel I have had no end of connectivity issues to the internet. Works for about a week then disconnects from the WiFi and is never able to connect to the designated 2Ghz WiFi channel again.

Enough is enough and the MainQ will be going back to hardwired again tomorrow via my unpreferred route of powerline adaptors.

Why the Mini's refuse to talk to the Main without an Internet connection is just odd? The MainQ displays its satellite channels without connectivity to the www, but for some reason the Mini's won't have any of it??

Everything I have ever thrown at my UniFi Wifi AP's to date connects to them without issue with the exception of these god awful SkyQ boxes.

Absolute shoddy equipment this supplied by Sky.!!
 

rhinoman

Well-known Member
Sorted it. It was related to IPv6. Apparently there is a bug on non Sky Broadband connections. Doable that and it works.
Disable that where? In the router or the SkyQ?
 

IL Cattivo

Distinguished Member
In which case the Wifi button will do nothing if Wifi has been disabled!

The symptoms you describe can be caused by having both a wired connection and a Wifi connection at the same time. I emphasise the "can"; there may well be other causes.
So far so good since I changed mine... [MainQ - Wired] [MiniQ-Wireless]

It's important to reiterate some facts for Wi-Fi connectivity on these shoddy devices using Non-Sky broadband equipment....

SkyQ Main boxes (For some reason) only like WiFi connectivity on the 2.4Ghz band only. If using Dual-band SSID [combining 2.4 & 5Ghz over one SSID], you will very likely hit issues with connectivity. The solution (and a very flaky one at that) is to separate the bands out and assign them individual SSID's.. Example> HomeWifi_2 HomeWifi_5 <-- This can be done on your home broadband router or wireless equipment,
From here the SkyQ Main box should be able to connect to HomeWifi_2 without issue (How long it stays connected consistently is another matter)

Now we come to the SkyQ Mini wireless connection. This little fiend only connects to the SkyQ Main box and not your home WiFi. It connects using a Sky Mesh signal from the Main Q box which is 5Ghz (Better bandwidth but weaker signal over distance). It's therefore important that these two are relatively close together with as few obstacles as possible in between them. Connectivity is achieved by using the WPS button (two circling arrows) on the front of each device when prompted at setup.

My experience is that I have had this setup above working but over time the MainQ decides it no longer wants to have anything to do with the 2.4Ghz signal and drops off. This then affects the MiniQ resulting in it serving no purpose other than it has now become a brick.

So I have recently taken the 2.4Ghz connectivity out of the equation and hardwired it through a 1GB HomePlug adapter which still gives me relatively good www speed to the MainQ.

Since setting it up this way I have yet to experience any issues from either SkyQ box.
** important - Reset your network settings from scratch on the MainQ - Don't just plug the ethernet cable into the back of the MainQ while it's still utilizing WiFi - Go through the Network setup from scratch selecting the 3rd 'wired connection' option listed. - You'll then need to do a similar reset of the MiniQ box.

So it's important (as others have mentioned) that to set it up this way, you must not disable any wireless function on either of the SkyQ boxes or they won't be able to talk to each other over the 5Ghz Mesh.
 
Last edited:

The latest video from AVForums

AVForums Movies Podcast: Streaming Theatrical Releases And The Future Of Cinema
Subscribe to our YouTube channel

Latest News

Melco update improves N10, N100 and N1 EX digital libraries
  • By Andy Bassett
  • Published
Loewe launches We.See TVs under new 'We. by Loewe' sub-brand
  • By Andy Bassett
  • Published
AVForums Movies Podcast: 1st December 2021
  • By Phil Hinton
  • Published
Rumour: Samsung even closer to OLED TVs in 2022?
  • By Andy Bassett
  • Published
Audio-Technica launches ATH-SQ1TW true wireless earphones
  • By Andy Bassett
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom