Sky HD - HDMI - Dolby Digital

Discussion in 'Home Cinema Buying & Building' started by ddgaine, Aug 6, 2012.

  1. ddgaine

    ddgaine
    Active Member

    Joined:
    Jun 17, 2012
    Messages:
    101
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Puckeridge, Hertfordshire
    Ratings:
    +4
    If this has been asked before then I am apologies.

    I currently have my Sky HD box running through my Pioneer VSX-1021 on HDMI - and obviously not getting 5.1 - despite Sky advertising program's being broadcast in Dolby. Now I obviously have the option at the back of said amp to run audio through an Optical line - my question is, is it possible to run the picture through HDMI and the sound through optical in order to actually make use of the 5.1............... Has anyone else had this problem (and solved it!)
     
  2. apj77

    apj77
    Standard Member

    Joined:
    Oct 16, 2009
    Messages:
    27
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    3
    Ratings:
    +1
    The sound has to be run through the optical cable as doesn't work through the hdmi lead with the sky box. Change sound settings on the sky box to digital optical
     
  3. apj77

    apj77
    Standard Member

    Joined:
    Oct 16, 2009
    Messages:
    27
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    3
    Ratings:
    +1
    Should say change digital audio output - optical to Dolby d
     
  4. ddgaine

    ddgaine
    Active Member

    Joined:
    Jun 17, 2012
    Messages:
    101
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Puckeridge, Hertfordshire
    Ratings:
    +4
    I have done that - still getting only through the two fronts and forced through the sub.
     
  5. Piers

    Piers
    Active Member

    Joined:
    Dec 11, 2002
    Messages:
    1,995
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Cheshire
    Ratings:
    +230
    Have you altered the amp's settings so that it knows to look for an optical audio input to use with the HDMI video input from the Sky receiver? If not, even though you have plugged in the optical cable the amp will still be using the 2 channel audio coming over the HDMI connection.
     
  6. apj77

    apj77
    Standard Member

    Joined:
    Oct 16, 2009
    Messages:
    27
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    3
    Ratings:
    +1
    Yeah you also need to switch the sound on the amp to digital optical for that device being your sky box
     
  7. DonH

    DonH
    Standard Member

    Joined:
    Aug 18, 2007
    Messages:
    17
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Location:
    Truro
    Ratings:
    +0
    I have a SKY+ HD box, Onkyo 905, etc.
    All my settings are correct but some Sky transmissions are NOT broadcast in DD when they say they are! I have gone from one movie not working to another which was working without problems (ie Dolby Digital fine) on many occasions. Happens a lot.
     
  8. leedspokerguru

    leedspokerguru
    Active Member

    Joined:
    Dec 6, 2007
    Messages:
    144
    Products Owned:
    1
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +14
    I run audio via optical on my onkyo with sky hdmi direct to TV.

    not sure if im jumping in and missing something out but assuming you only get surround sound (all your speakers) on some broadcasts and just fronts on others........

    obviously make sure onkyo is to optical for your sky, which is looks like you have. Is there a slight delay of audio kicking in when switching channels from a DD source to another?? If so below might help.

    The onkyo also has sound preset modes (eg. neo cinema, mono etc..) that are used depending on what source is being detected ie what the sky channel is sending. So if you go from a DD movie on sky movies to one of the naf music channels that only output stereo the preset would change.

    If you go into the set up on the onkyo there should be a list for the presets. Make sure the output is greater than 2 channel audio on the various presets. Make sense???

    To give you an example of how I set it up.

    If the onkyo detects Dolby Dig via the optical it outputs via the dolby dig preset.
    If it detects stero audio feed or anything <DD i have them all set to output via neo cinema 6 preset for example, which uses all 5 speakers.
     
  9. Mario Nicholas

    Mario Nicholas
    Active Member

    Joined:
    Apr 2, 2002
    Messages:
    820
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Surrey
    Ratings:
    +86
    The only thing I would add to this is that I prefer to listen to sound formats as they were recorded, so DD in DD and stereo in stereo, but I accept that it is subjective in some setups.
    With regard to audio switching correctly, I know this may sound obvious but the sound is coming out of the optical regardless of format so to test this connection, unplug the hdmi and the sound should remain. (BTW a lot of AV kit is damaged by unplugging/plugging in of hdmi cables so to be on the safe side, turn both units off when doing so)

    HTH
    Mario
     
  10. benjani

    benjani
    Banned

    Joined:
    Apr 12, 2010
    Messages:
    497
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Gloucester & Preston
    Ratings:
    +99
    You need to asign your Optical in your AVR or it wont work. Set it to auto then it should pick up different sound formats, etc.
     
  11. harveydog01

    harveydog01
    Active Member

    Joined:
    Aug 1, 2010
    Messages:
    99
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +3

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice