• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Sky HD Digital Audio Output issues

GMcD1

Standard Member
Trying to connect SkyHD box through Kenwood 5.1 Amp

When using Coax it works ok with 5.1 coming through, however every few minutes the sound drops out for about half a second (can get very annoying!!).

When using optical, the amp registers that it's receiving a Digital 5.1 input signal, however there is no sound at all, even at max volume on amp. I'm using an optical switch box but have also tried direct with the same result.

Any ideas??
 

GMcD1

Standard Member
No, does it regardless of what's on, was doing it through an on demand film and also on bbc during programmes
 

AV Junky

Active Member
If it does when connected directly, then next step would be a cable check. Need to have another cable to do that one of course. After that, consider a tech support request to Sky.
 

logiciel

Moderator
Or a different switch, or none at all!
They're totally erratic, especially with Sky machines, and of course it depends on what else is connected through them.
 

GMcD1

Standard Member
Thanks all

Tried various combos of cable etc and direct and through switch and still nothing. Strangely, with coax, watching F1 recorded on HDBox 37 laps in and no sound drops so far, absolutely fine.

Have looged a tech call with Sky so we'll see what comes back.
 

logiciel

Moderator
If the problem happens without the switch then the optical plugs aren't firmly in their sockets, or the sockets themselves are faulty.
I wouldn't expect Sky to do much about either.;)
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom