Sky+ HD box sound sync issues with JBL 9.1 sound bar

Epidural20

Standard Member
Hi all,

I recently purchased a JBL 9.1 sound bar and I’ve been very happy with it so far- especially withhow it plays with Netflix, Amazon prime and Disney+. However, I’m having serious issues with Sky+ HD 1Tb box. When the sound on the sky box is set to Dolby instead of normal, the sound on some of the HD channels goes out of sync. When I try to adjust the delay on the sky remote, it just makes it worse. I’ve tried everything. Including restarting the sky box etc. Nothing seems to resolve the issue. When the sound is set to normal on sky box, and therefore just pcm on sound bar, the sync issue goes away.

Just for reference, my set up is as follows. Sound bar is connected to my Samsung tv via hdmi eArc. Sky is connected to tv via hdmi.

The sound bar has an optical connection. And so I thought I would be clever and connect the sky box directly to the sound bar this way and see if it resolves the sound sync issues with the he channels so that I can finally listen to things in Dolby 5.1. But when I tried to do this, my sound bar doesn’t seem to pick up the sound via optical. I’ve checked to see if it is connected properly and it is. But there is no sound. It’s just picking up the sound directly from the hdmi connection from the tv. Very frustrated here. Does anybody know how to resolve this? At the very least does anybody know how I can set the sky box to distribute sound just through the optical connection and not through hdmi?

thanks
 

dts

Distinguished Member
You need to change the sound settings in your sky + HD box to optical and the select Dolby.also try changing the lip sync settings in the sound menu.
 

Epidural20

Standard Member
You need to change the sound settings in your sky + HD box to optical and the select Dolby.also try changing the lip sync settings in the sound menu.
Hi there,

I’ve tried them both.

I’ve changed the sound on the optical to Dolby but the sound bar is still picking up the sound from the hdmi instead.

and I’ve tried the lip sync adjustments on the sound menu but that just makes the delay worse.
 

The latest video from AVForums

LG G1 OLED Evo TV and SVS SB-1000 Pro subwoofer reviews, Samsung OLED rumours and more...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom