Sky HD+ 2 boxes Still initialising

Colin Glover

Active Member
So I bought a Philips 50 pus7505 and I'm pleased with it. Had two old sky boxes, and our new house has sky cabling (shotgun) in every room. So set a Sky+ HD box to run in Freesat mode worked well, but was far away from TV. The leads were dodgy, they kept coming out of the screw in sheath. Bought an extension, which worked if cables were pushed in tight. Tried an extension into the sat socket on TV this morning. Worked with lead pushed right into extension. Decided, as TV only used One connector, to run remaining single lead to try both side by side. Had to run setup menu to change box to work on one cable. Box reset itself and then kept showing the "Still initialising try" later message. Tried several methods to reset from web, all failed. My friend redid connectors properly. Still showed error messages. The TV satellite in connection now keeps saying no satellite connection detected, as does the sky box. Tried a mini sky box as well, both boxes show the still initialising message. A web page said might be a signal error. I can't believe two previously working boxes can give the same message, as both had been working perfectly. Any ideas pls guys? Were wondering if old cable is damaged, but if that were the case, box wouldn't work at all. Can't be two faulty boxes giving same error.surely!
Cheers, Colin.
 

The latest video from AVForums

AVForums Movies Podcast: We review Dune and ask which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom