1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Notice: AVForums will be offline at 10pm for no longer than 30 minutes for scheduled maintenance. Apologies for any inconvenience this causes.
    Dismiss Notice

Sky+ causing hifi hiss

Discussion in 'Sky Digital TV Forum' started by stickybz, May 18, 2005.

  1. stickybz

    stickybz
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi
    I have just upgraded to sky+ and have developed an annoying hiss through the hifi. This is present on all amp channels (not just sat) and disappears when the sky box is in standby mode, and is not dependant on amp volume setting. The digibox is a few feet from the hifi but, due to limited space, the 2 cables from sat dish do pass close to the speaker cables (no easy way around this). The sky+ box is connected through an optical link to the amp.
    Ive tried moving power cables etc with no luck. Do I need to consider upgrading the 2 cables from sat dish to box? If so any recommendations? :lease: Isn't this something the sky installers should do?

    Thanks in advance.

    ------------------------------------------------------------------------
    Sky+ Pace 3100, Arcam AVR250/DV79, Kef Q7/2Qds/Q9c
     
  2. JayCee

    JayCee
    Well-known Member

    Joined:
    Jan 20, 2004
    Messages:
    20,082
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Lanarkshire
    Ratings:
    +1,914
    The coax cables from the Lnb on the dish to the Sky+ are unlikely to be the cause of the hiss......have you tried disconnecting the optical lead and tried maybe a phono to phono to see if the hiss is still there?

    Well, if you have upgraded from Sky digital to Sky+ surely they had to run another coax from the dish? :rolleyes:
     
  3. stickybz

    stickybz
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Nope that didnt do it, thanks for good idea though.
     
  4. sillybeans

    sillybeans
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Whats the volume like through the tv without the amp? Have you tried another scart cable? (Should not make a difference but worth a try)
     
  5. Nick_UK

    Nick_UK
    Banned

    Joined:
    Nov 13, 2004
    Messages:
    9,748
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    103
    Ratings:
    +270
    The hiss is probably being generated by the switched-mode power supply in the Sky+ box, and picked up via the amp power cable. Since the hiss is independent of the volume control, it is unlikely that it is being picked up by other wiring. An in-line power filter or clamp-on ferrite filter could be the answer.
     
  6. stickybz

    stickybz
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    thanks again for the advice. Have just ordered a ground loop isolator (before reading your posts). If this doesnt work think ferrite plugs will probably be next step.
    Cheers (Ill let you know if it works)
     
  7. stickybz

    stickybz
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    just an update. The ground loop isolator was delivered through the cat flap. My lab was very pleased at her new prezzie and bit it into little pieces! Gave up with the idea and bought a belkin mains extension (with filters). The hiss is now inaudible at normal listenening distances. Thanks again for all the advice.
     
  8. anthonyg

    anthonyg
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I've got a belkin doo dah, pretty nifty for the price (£70) 8 way extension with power cleaning and surge protection on mains, RF, telephone and sattelite (though it only as one sat filter, they didn't count on sky+)

    .
     

Share This Page

Loading...