1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sims 2 and GeForce 6600 Graphics Problems

Discussion in 'PC Gaming & Rigs' started by jshaw_82, Sep 21, 2005.

  1. jshaw_82

    jshaw_82
    Active Member

    Joined:
    Dec 13, 2004
    Messages:
    185
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Derby
    Ratings:
    +3
    I have recently bought a new graphics card, the GeForce 6600 (AGP), having installed it in the computer and installing the latest nVidia drivers (78.01) for it the graphics card seemed to be okay. However once i come to play the Sims 2 or University, once the game has loaded to the stage (Pleasentview or something) there are bits of graphics missing, little triangles and when you load to a house there a sections missing from faces and sinks and other bits. then after about 30 minutes the game crashes.

    I have a ECS KS57A Motherboard with the latest BIOS with an Athlon XP2400 Processor.

    So things i have tried to resolve so far -
    - Taking all the default settings in the game to low.
    - Reinstalling both Sims game, and University Expansion Pack.
    - Tried different resolutions.
    - Ran DXDIAG and tested all GFX options - all good.
    - Installed all the drivers that have the 6600 support on them - from 66.93 onwards.
    - Tried various Omega Drivers suggested from other forums.
    - Updated the AGP drivers for the motherboard

    Now i have managed to get the game to run properley, what i had to do was to download the nVidia 61.76 drivers (which doesn't have 6600 support) and when installing the GFX drivers tell the PC it is a 6800 GFX card. This worked and allowed the game to run properly, however Video playback through Winamp or VL or Windows Media Player was corrupt. To describe this Video playback would work in a small screen but once resized after a certain size (and including full screen) the video would split in half diagonally from top left to bottom right, the top right side being clear picture and the bottom left side being all corrupt.

    I have tried other methods like telling the computer the GFX card is a 5700LE (the card i had before), using old nvida drivers (56 or something), but then the pc would not get past the XP logo so had to system restore.

    Anyone got any ideas???
     
  2. HMHB

    HMHB
    Distinguished Member

    Joined:
    Nov 11, 2001
    Messages:
    25,459
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    Nottinghamshire
    Ratings:
    +3,764
    Is there a patch available for the game from the Sims2 website that you may need to load ?
    I noticed on one of the FAQ on the Sims2 site that it recommends to set the screen to 1024x768 - have you tried that ?
     

Share This Page

Loading...